Skip to main content

How do i connect my mixer to the Sound Card

Member for

21 years
Hey guys, i got a mixer and i just cant get it to work.

the mixer is a europower pmh1000 behringer

and my sound card is a creative Extreme Fidelity

i want to connect that to my pc so i can use it for recording.

at the moment i just have a normal set of speakers so i need to know how to connect them too.

Thank you for any one who trys to help me

Comments

Member for

15 years 10 months

hueseph Mon, 06/16/2008 - 11:37
Trying to avoid bashing here but since you are going through those two fine pieces of gear you will need a dual rca to single 1/8" stereo phone plug. You can buy one at your local dollar store or if you want the ultra version you can go to Radio Slack or Best Buy. Go from "tape out" to your cards LINE in. You can leave your computer monitors plugged into the soundcard. That's fine. Remember though that you will be creating a submix no matter how many channels that mixer has. So, no editing individual instruments after the fact if you record them in one take, so make sure you get it sounding right before you go to disc.

Member for

21 years

Member Tue, 06/17/2008 - 08:13
Hey guys, i hvae tried this and failed.

i dont know if i did it right tho, because am not sure where the line is on the sound card because its not written on it. so i tried all the plugs and the only one that gave me sound was the speaker plug.

my microphone is not working either so if any one can help i be thankful

Member for

21 years

Member Tue, 06/17/2008 - 08:20
It should have little symbols on it to help with the illiterate.

Some curved lines like this ))) and an arrow --->.
If the arrow points toward the hole thats a line in.
If the arrow points away from the hole thats a line out.
If there is a picture of headphones, that's a headphone port.
The little picture of a microphone or ice-cream cone, this is a microphone port.

In the event your ports have no handy pictures, they should be colour coded. You need to assign the ports in your driver software. Last time I dealt with this the colours in the software didn't match the ones on the card so good luck.

Member for

15 years 10 months

hueseph Tue, 06/17/2008 - 08:31
After or even before you plug into the line in jack, make sure that the input is enabled in the windows mixer. There should be a speaker icon in the bottom right hand corner of the screen. Right click on that and select "open volume controls". Select Options/Properties/Recording/make sure that line in is enabled in the menu box and select "ok"/ Now make sure that line is selected as your record device. Deselect anything else that might be enabled as a recording device.

Member for

15 years 10 months

hueseph Wed, 06/18/2008 - 08:37
What program are you recording into? What are you recording? There are three controls that will affect the volume: channel trim or gain, channel fader or level knob and the stereo main on the mixer. Also make sure that if there is a "To mix"or "to tape" switch, it is engaged.

Member for

21 years

Member Wed, 06/18/2008 - 10:55
You need to configure the "wave in" settings in Audition to look at your line in port on your card.
That's if all the other things are working.

What mic(s) do you have?
How many vocalists are you going to record at once?
Why do you have that mixer?
Why would you expect a multi-media card to be good for recording?
Have you tested your mixer and mic with some speakers and an amp to be sure you have a signal path through your mixer?

Do you have manuals? They're so chock full of on topic information it's not funny.

Please answer all questions.

Tags

x