Skip to main content
forums, blogs, song critique, support & more...

How do you like the new forum?

I waited almost 2 years to upgrade our forum. Today its now current. There are some things that may not migrate over but I'm working on it.

How do you like it so far? Any suggestions?

Comments

Profile picture for user Kurt Foster
Member for
18 years 11 months

Kurt Foster Thu, 02/11/2021 - 12:41

bouldersound, post: 467433, member: 38959 wrote:
I always try to clean up links. If you copy the link from the address bar on page in question, everything up to the question mark is the link, everything from the question mark to the end is the tracking data. Don't copy links to non-FB sites from FB.

i didn't know i could do that. will start doing t immediately. thanks for that.

Profile picture for user bouldersound
Member for
11 years 4 months

bouldersound Thu, 02/11/2021 - 12:58

Kurt Foster, post: 467434, member: 7836 wrote:
i didn't know i could do that. will start doing t immediately. thanks for that.

There are some cases of dynamically generated pages where there's a question mark in the address. Don't delete that information. They tend to be a lot shorter than links with Google tracking data anyway.

Profile picture for user kmetal
Member for
11 years 10 months

kmetal Sat, 02/13/2021 - 23:54

works fine once i manually typed in the ro address in chrome/ andriod.

What kinda stuff can we do with the cms, is there a feature list or something? Looking forward to seeing how it works!

Profile picture for user audiokid
Member for
20 years 9 months

audiokid Sun, 02/14/2021 - 08:14

Tony Carpenter, post: 467497, member: 48344 wrote:
Found this out the hard way today LOL :). Thanks Chris.

Does the the forum not redirect to its new url? It does for me and I've tested it on quite a few browsers.

Profile picture for user Boswell
Member for
15 years 1 month

Boswell Sun, 02/14/2021 - 09:37

audiokid, post: 467498, member: 1 wrote:
Does the the forum not redirect to its new url? It does for me and I've tested it on quite a few browsers.

What I found is that if you leave the forum open when you shut down the computer (or use Sleep), then it does not always redirect properly when the pages recover on a re-start. If you close the RO forum tab and re-start it, it maps to the community folder correctly. I've tried Firefox, Edge and Chrome, and they all do the same thing, so I think it's a Xenforo problem.

I've noticed a separate effect when quoting posts. It often (but not always) needs two clicks on the original "+Quote" button for the quoted post to be available for insertion in your new text. I've only tried that using Firefox.

Profile picture for user audiokid
Member for
20 years 9 months

audiokid Sun, 02/14/2021 - 09:41

Boswell, post: 467499, member: 29034 wrote:
What I found is that if you leave the forum open when you shut down the computer (or use Sleep), then it does not always redirect properly when the pages recover on a re-start. If you close the RO forum tab and re-start it, it maps to the community folder correctly. I've tried Firefox, Edge and Chrome, and they all do the same thing, so I think it's a Xenforo problem.

I've noticed a separate effect when quoting posts. It often (but not always) needs two clicks on the original "+Quote" button for the quoted post to be available for insertion in your new text. I've only tried that using Firefox.

Thanks for this update, Bos. What does the forum do (or look like) when it doesn't redirect? Do you just see folders with directories?
I get the same quote issue too. Its annoying. Hopefully xenforo fixes this on there next maintenance update.

Profile picture for user Tony Carpenter
Member for
6 years 9 months

Tony Carpenter Sun, 02/14/2021 - 10:07

audiokid, post: 467498, member: 1 wrote:
Does the the forum not redirect to its new url? It does for me and I've tested it on quite a few browsers.

No idea now Chris :). I edited my url in chrome bookmarks to update. Thanks for your work as usual :).

Profile picture for user Boswell
Member for
15 years 1 month

Boswell Sun, 02/14/2021 - 10:07

I've just tried a couple of sleeps on Firefox, and it recovered correctly both times. What ever it was you did, it seems to have worked!

Profile picture for user audiokid
Member for
20 years 9 months

audiokid Sun, 02/14/2021 - 10:19

Erk... I unfortunately trusted the support forum for rewrite rules before I did all this, that didn’t work.
Spend hours going in circles using bad rewrite code. So annoying.
My apologies to the community.
I think we’ve got it configured now.

Profile picture for user cyrano
Member for
3 years 4 months

cyrano Sun, 02/14/2021 - 10:42

audiokid, post: 467498, member: 1 wrote:
Does the the forum not redirect to its new url? It does for me and I've tested it on quite a few browsers.

My bookmarks (to "new posts") still work without change on several macs and iOS devices.

Profile picture for user audiokid
Member for
20 years 9 months

audiokid Sun, 02/14/2021 - 18:31

kmetal, post: 467493, member: 37533 wrote:
works fine once i manually typed in the ro address in chrome/ andriod.

What kinda stuff can we do with the cms, is there a feature list or something? Looking forward to seeing how it works!

(edited with some updated cms features)

We're still a ways to go before I can implement the CMS the way I hope because our current xenforo software developers don't seem to want third party code being used with their forum. I feel it will be their demise if they don't get on board with what is going to be mainstream (SSO) soon enough.
Think of it like MIDI and how that revolutionized the entire music industry. Good code should be able to talk to other products these days. Especially (SSO) "single sign on" login credentials .
Modular integration with other products are the future.

Right now I have both Drupal and WordPress installed ready to go. I much prefer Drupal because it is extremely secure and packed with features. Either CMS, as of today, members would have two separate logins/ two separate accounts on recording.org. It would be confusing for those not realizing why they can't login to one of the two after they just registered.
One login for the CMS and one for the forums... .

Never the less, despite the two logins... I may still open it up for the members that want to use it.

Regarding what it would include. Basically just ask what you'd like us to have and we may be able to install it.
We'd start with

  • front page
  • blogs
  • business websites ( everything music related)
  • tutorials
  • directory
  • taxonomy
class="xf-ul">
x