Skip to main content

Latency Issue. Guitar Input > USB 2.0

Member for

21 years
Hi People.


my situation :

I recently bought Native Instruments' Guitar Rig.
Though I am not running it via their Rig Kontroller

Instead I bought myself the Light Snake™ ¼ Guitar input > USB 2.0 cable. It's a nice cable.

Now when GR loads and I go to the AUDIO AND MIDI SETTINGS I have 2 options and they are as follows:

1. DirectSound / 2. Multimedia

both of which are asking for input and output devices of which I assign their respective hardware.

my LightSnake for the input and my Speakers for output.

(question 1) Which is better for quality/recording purposes > DirectSound or Multimedia ?. The Light Snake came with drivers but I do not see their options available anywhere.

and so...

I select DirectSound my speakers are set to 30ms and my guitar input set to 50ms
I've tried adjusting the hell out of these two ms latency sliders but nothing helps as far as improving or totally
eliminating latency.

It's unnerving as I am unable to play or record anything since the latency makes it impossible to hear what I am playing.
The faster you play the more mashed the sound becomes.

(question 2) What are my options for minimizing/destroying latency from my guitar to pc experience?

I read the manual to the Light Snake regarding latency improvements but It didn't solve anything.


Any knowledge or help on this subject would be kindly appreciated.

here is what I am running it all on : Intel E6550 Core 2 Duo, 2333Mhz x 2 physical processor count with 2045Mb memory.

Thank You,

Comments

x