Skip to main content

Mbox 2 Mini Vista SP1 Compatability

Member for

21 years
Hey,

I was just about to buy the Digidesign Mbox 2 Mini, when I noticed it says that its not compatible with Vista SP1. Now I have Vista Home Premium (32 bit) so thats fine, but I have upgraded to Service Pack 1 .........It says an announcment will be made in March 2008 ? and thats all there is on the website ?

So does anyone know if its compatible with Vista SP1 yet?

Comments

x