Skip to main content
forums, blogs, song critique, support & more...

Multiple interfaces in Cubase

Hi. I'm on Windows XP using Cubase SL2.3. My interfaces are a Tascam FW1884 and a RME Fireface 400. How do I get these to comunicate? ADAT? If so, I must be missing something cause they won't work.


Profile picture for user hueseph

hueseph Tue, 05/15/2007 - 16:15

You can only have one ASIO device active at a time. There is a website promoting a third party ASIO driver which is supposed to allow for multiple firewire devices in daisy-chain however, they currently have a limited list of supported devices. Google it. I'm sure you'll find something.

Appleseed Wed, 05/16/2007 - 06:12

Shouldn't I be able to connect one via ADAT?

Or has anyone been able to ise ASIO4all effectively? I've got data to transmit using this driver but it crashes my system. Right now both are going through the same Firewire card on my PC. Does that make a difference?

Profile picture for user hueseph

hueseph Wed, 05/16/2007 - 07:31

The problem is that the ASIO driver is your audio driver. If you can only have one ASIO driver available at a time, only one device will work at a time.

Appleseed Wed, 05/16/2007 - 11:39

How about this:

1st, I miss-spoke. I actually have a RME 800 not 400

According to the specs, I can run multiple inputs on the front jacks simoultaneously. Just how many converters are in this because I was under the impression that there were 10? (which is what I'm running now) The specs say 35 input sources rare available recording 28 tracks at a time! That'sbe more than enough.

If I could do that, than I'd just dedicate my FW1884 as a controller only.

Here's the catch: They're both Firewire. Can I run the RME through Firewire for inputs and the controller through something else?

Profile picture for user hueseph

hueseph Wed, 05/16/2007 - 13:19

The FW1884 will, of course, still have to be plugged in via firewire and you could certainly use it simply as a controller. You should be able to set this up in the devices menu.

Regarding the RME, there are 10 converters. One for each physical analog input. The additional channels will already be digital via adat/lightpipe.

Appleseed Wed, 05/16/2007 - 14:17

If that's the case, running the light pipe still should work with my 1884 which it does not. It possibly could still be the driver issue again right? Or does ADAT bypass the whole driver issue?

Profile picture for user hueseph

hueseph Wed, 05/16/2007 - 15:20

Still the driver issue. I suppose you could try it. The unit is still getting power. The only thing is, aren't the converters in the FW1884 driver dependent or are they independent of the drivers?

Appleseed Thu, 05/17/2007 - 07:35

Good question. I really don't know but I'm guessing dependent. I would buy another RME if I knew for sure both would run. However, how would I connect my FW1884 as a controller if the RME is Firewire as well?

Appleseed Fri, 05/18/2007 - 06:29

OK. I'm getting close:

I connected my FW1884 with 1 ADAT going out to the RME ADAT In. Then slave it to the RME Wordclock. I got data to record off both units without a crash. However, I'm only getting 2 channels out of the 1884. And it's inconsistant as to which inputs are going to work. I'm going to try going the other direction and Slave the RME to the 1884 and see if I get any better results but am I missing something on the ADAT connection? Should I use 2 cables?

I can almost taste it I'm so close!

Appleseed Fri, 05/18/2007 - 18:22

No, I think everything is routed right. I don't know. I reversed everything now. FW1884 is running the show and I'm getting signal on each channel (plus control surface is back!!!).

1884 is running on channels 1-8 firewire, RME is running channels 9-16 via ADAT. Thing is, channel 9 and 15 get signal from whatever other RME channel is active (?!?!) It's wierd. Channel 9 is routed to ADAT 1, 10 to ADAT 2 and so on, but Chennel 9 and 15 always get signal when they shouldn't. Has to be some kind of routing problem. Or do I need another ADAT cable running between the 2?

Appleseed Fri, 05/25/2007 - 07:00


Hello and Good morning!

Here's some good news for Cubase opperators wanting to run multiple interfaces.

My Tascam FW1884 is running the show through Firewire and my driver is set on FW1884 in Cubase. My RME Fireface 800 is recieving wordclock info from the 1884. A single ADAT cable runs OUT of the Fireface and IN to the Tascam. Both units are connected to the same Firewire card in my computer.

On my bus list in Cubase, Inputs 1-8 are Analog from the Tascam. Inputs 9-16 are ADAT 1 from the RME. Output (Monitor) is routed through Analog out 1 & 2 on the Tascam.

The secret is the routing. On the RME mixer screen, go to View-Matrix. The grid comes up with boxes highlighted all over. This is hard to explain without graphics but I'll try. The upper left corner is your inputs (1-10)
As you look right, you see SPDIF outs, and ADAT outs. Now this is important: on the outs, click the ADAT1 chnl 1 out to use Input 3 as it's source. ADAT1 chnl 2 for Input 4, ADAT1 chnl 3 connects to Input 5, and so on until you get to Input 10.

The reason the numbers won't match is because ADAT can only transmit 8 channels. Well the RME Preamps don't start until channel 7. Therefore if 1 went to 1, 2 went to 2, 3 went to 3, etc. by the time you get to channel 9 and 10, you've ran out of ADAT channels.

This set up gives you 12 simultaneous tracks. On the back panel, you have your Direct balanced ins 1-8. These feed the AD converters 1-8. I believe Channels 5 - 8 are already used by the front panel's preamps 7-10. So that means we can insert 4 outboard preamps into the first 4 inserts on the back giving us.....that's right! 16 tracks!!!! With a little more experimenting I may even be able to squeeze out another 2.

16 tracks running at the same time with no latency and full DAW control surface capability!

Oh happy day.


dementedchord Fri, 05/25/2007 - 07:37

have you actually tracked 16 at once yet???? i'm glad it's working for you... and like you said maybe it doesnt make sense without the graphic... but something doesnt sound right here... cant argue with sucsess though...

Appleseed Thu, 05/31/2007 - 07:46

Yes all 16 are running and recording. Little issues though: After recording, playback won't produce any sound nor did the meters run. I disabled track 1 and then enabled it which made the meters start to work again showing that indeed everything had recorded. Still no audio though. Possibly something in my FW1884 that needs re-routing or enabled on the monitor side.

Appleseed Fri, 06/01/2007 - 06:59

This is kinda funny and embarassing. 16 tracks running all at once now with no noticable latency AND monitoring during playback. For some reason the output bus on each channel went to "no bus!" I just popped everything back to Stereo Out and away we go!

Tell the world. It's possible!!!