Skip to main content

POPS AND CLICKS WHILE PLAYING/RECORD MY MIDI CONTROLLER

Member for

21 years
When I play the midi notes Im getting pops and clicks even when I record in logic I get the pops and clicks . Has anybody had this issue and how do I solve it?

Comments

Member for

16 years 7 months

pr0gr4m Sun, 12/30/2007 - 02:31
The drawbacks are latency. For example, if you are recording something and monitoring the recorded signal, you would hear a delay between the time you play (or sing) and when you hear it. This is not a problem with playback/mixing but it can be a problem with recording because it can throw off the timing...because the musician doesn't hear what they are doing when they do it.

The only real way to improve that is via hardware; faster computer, better audio interface, etc.

It's also dependant somewhat on the material in the song. Some songs that use a lot of plug-ins may require a higher setting. It's one of those things that may need to be tweaked from time to time.

Member for

16 years 7 months

pr0gr4m Fri, 12/28/2007 - 01:56
...Even when you record WHAT in logic; MIDI, audio or both?

What audio interface are you using?
What MIDI devices (hardware and software) are you using?

Pops and clicks can happen for lots of reasons, but one of the most common reasons for it to happen during recording is buffer size. A small buffer can cause problems with audio. Try increasing that and see if you get better results. But there are drawbacks to using a larger buffer, but lets deal with the pops and clicks first.

Member for

21 years

Member Fri, 12/28/2007 - 08:31
Looks like setting the buffer size alittle larger in logic worked. I never had to do that before, I could always keep it low. Im using a m-audio axiom 25 keyboard and running Voices Of Passion from East West and that runs the Play interface. So whats the drawbacks to using a larger buffer size.
x