Skip to main content

problems with iMac recording

Member for

13 years 11 months
hi everyone.

most of the time it's a non-issue, but occasionally when i try to record into logic, i'll press the record button and logic will stall for anywhere between 30 sec. to over 3 minutes. the mouse arrow turns into that damn pinwheel thing. eventually it will get started and works fine, but whenever that happens, it will continue to happen whenever i record in that session.
also, it doesn't matter whether there are 12 tracks in that session that each have active plugins or if the session is brand new with no tracks/plugins.

it doesn't make sense, because the processor meters are stable, and i can open other programs while logic is stalling. another weird thing is that if i start "session a" and this problem happens, it happens whenever i track into that session. usually if i close that session and start "session b" then that session is fine, but if i reopen "session a" it happens again. (i hope that made sense).

my setup consists of a firepod going into a new intel-based iMac. it has core 2 duo processing and 3gb of ram. i should also mention that i tried garage band and it happened there also.

has anyone ever experienced this?

any advice would be greatly appreciated


Member for

13 years 10 months

FlyBass Fri, 12/14/2007 - 04:54
I know this may not help -- I have an iMac (PPC G5, 1 GB ram, 10.4.11), Logic Pro 7.2.3, and a PreSonus FirePod, but I have never had your problem.

It sure does sound like your program is looking for something. Are you running Logic Pro 7 or 8? If you are running Logic Pro 7, the computer may be running in Rosetta and this may be the problem. Or...

...from Apple:
"Sometimes, you might have a Universal version of a graphics or Internet application on your Intel processor-based Mac that you want to run via Rosetta instead of running natively. Because some Universal applications may continue to rely on existing plug-ins, you may sometimes need to force a Universal application to run in Rosetta to accommodate the plug-in. Check with your plug-in manufacturer(s) to see if Universal versions are available, too.

Here's how you can force a Universal application to open using Rosetta:

Click the application's icon in the Finder, such as Safari's icon.
From the Finder File menu, choose Get Info (or press Command-I).
Select the checkbox named "Open using Rosetta."
Close the Get Info window.
Now, when you double-click the application, it will open with Rosetta, and any non-Universal plug-ins should work."

Member for

13 years 11 months

RecordingNewb Fri, 12/14/2007 - 08:56
Problem Solved!!!

i figured it out. i feel kinda stupid for not having tried this already, but because it's supposedly a huge no-no to record to your computer's hard drive, i never actually have tried it.

now that i have, the problem is 100% gone. meaning that it was the usb hard-drive all along. which makes sense that it happened on the other iMac because i was using the same hard drive when i tried it.

thank you all so much for your help. bent you were right all along. i guess it's time for a firewire hard drive...

Member for

15 years 10 months

hueseph Tue, 12/11/2007 - 11:48
You are recording to your system drive aren't you? This is why everyone keeps insisting that an external hard drive is necessary when a secondary internal drive is not possible. Writing to your system drive is a big no no. Your OS already requires the info on that drive in order to do it's thing. Adding the load of having to read and write audio to the same disc will cause glitches like the one your describing. External drives are cheap now. You should be able to pick up a 200 gig drive for a little more than $150.00.

Member for

13 years 11 months

RecordingNewb Tue, 12/11/2007 - 12:25
thanks for your replies fellas.

actually i am recording to an external drive. it's a 260gb seagate with 7200rpm drive. oh, and i've also tried another ext. hard drive once, and the same thing happened.

that's the thing though. i don't think the processor is tapping out, because i can minimize the logic window and open up other programs while logic is stalling, and they run fine and aren't even slower than normal.

bent did you mean firewire for the hard drive or interface? i'm already using the firepod, so i'm guessing you meant hard drive. the only problem is that the imac only has one firewire slot, there's also a firewire 800 slot, but are there even hard drives on the market that are firewire800 yet?

oh yeah, one other bit of info. i thought maybe the problem was with the firepod being defective, so i tried it on a pc laptop which worked fine. when i tried it on my buddy's G5 iMac using garageband, however, it happened on his computer also.

Member for

13 years 10 months

bent Wed, 12/12/2007 - 09:03
bent did you mean firewire for the hard drive or interface?


You say it worked fine on a PC, but you witnessed the same problem on two iMacs?

Hmmmm... Interesting...

What does Presonus' support site say about that (probably very little)?

Which OS are you operating?

I don't know much about Macs, but I do know that those OS versions are very important for some software / hardware configurations.

Member for

13 years 10 months

bent Wed, 12/12/2007 - 10:26
This fix might work (something similar had to be done on a MOTU I had, but that was on a PC):

1. Open the Audio MIDI Setup application located at MacHD/Applications/Utilities/Audio MIDI setup.

2. Select Audio Devices and set all to your PreSonus interface.

3. Underneath "Properties for:", make sure "clock source" is set to 'Device'. If it is set to 'Mac', change to 'Device'.

4. Disconnect your interface and restart your computer.

5. After your computer has booted, reconnect your interface. Clock source should be defaulted to 'Device' and you should now have audio.

Sometimes things like that (that seem to have nothing to do with your specific problem) can fix it...

If not, I'm at a loss...