Skip to main content
forums, blogs, song critique, support & more...

RME Fireface 800 Troubles

Well, for the second time in less than a year, my FF800 took a dump on me.
What's wrong? The red "Host" light never extinguishes, and the computer cannot recognize the unit. Effectively rendering it DEAD.

The first time it happened, the retailer replaced my B-stock unit w/ a new one, minus the upcharge. That was nice, minus the 2 week turnaround.

Both times, it was at session start - session canceled, no work done.
Nothing more frustrating than having clients sit and watch you be frustrated/befuddled as to why your $1700 interface just stops working. After an hour or more of attempted fixes, I had to send them on their way and contact support.

I know I've joined the ranks of members praising this unit, but the main reason I made the leap from Presonus to RME was to eliminate stability issues.

Now I'm out of business, until further notice. Hopefully I can make my old Presonus unit do until a solution is arrived at. Yeah, my Presonus is MORE RELIABLE. :confused:

Thank you, RME.
(last line edited to remove expletives)


bigtree Thu, 04/14/2011 - 14:17

yikes, we, don't read these kinds of issues very often. Are you sure its not your CP doing something. Maybe a weird Firewire/ bus issue.

Profile picture for user soapfloats

soapfloats Thu, 04/14/2011 - 14:57

Nope, tried a couple of FW ports/cards, and tried it on my MacBook.
It's either the FW port on the unit itself, or something else on the unit.
It worked wonderfully since last May, minus the two above-mentioned exceptions.
I'm confident the people at RME and their distributors will provide a satisfactory solution - at some point.

The biggest hurt is the inability to conduct business in the meantime - recording, mixing... I can't even listen to my personal music while cleaning the space.
Not mention, the inability to pay the bills when they come due, as no $$ is coming in.

On that note, maybe I should turn the studio into a rehearsal space in the interim? :frown:

Profile picture for user TheJackAttack

TheJackAttack Thu, 04/14/2011 - 15:22

I am sorry to hear about these troubles. I have two running myself without issue. One thing that can zap the firewire ports is when the cables are plugged in or pulled out. After RME/Syntax fixes the problem, make sure that cables aren't bending the firewire cable where it's plugged into the unit. It has the hook right there to loop around prior to insertion to help ablate that issue. I've got both of mine running into an Express Card 1394B adapter (separate laptops) that does NOT provide bus power at all on purpose. So my chain is Express Card-->Glyph GT050Q-->FF800. The GT050Q actually parallel chains to a GT051 as well.

Now all that said, I had an issue about three months ago and when I really tracked it down, the end of that particular 9 pin firewire cable was broken at the strain relief. I replaced the cable and was back in business. Have you tried a different 9 pin cable yet? How about a 6 pin cable? The one 9 pin port is attached to the 6 pin port FYI.

Profile picture for user soapfloats

soapfloats Thu, 04/14/2011 - 16:11

Thanks guys - I knew you two would chime in rather quickly.

Unfortunately, the PC only has a 1394a port. I have a card w/ multiple 1394a/b ports, but it won't fit the mobo.
I actually tried to do this (FW card and 1394b cables) last week, so as to ensure maximum bandwith. See above as to why it didn't fly.
I did try 3 different 1394a cables. And checked them w/ the old Presonus unit, which connected just fine.

Since you mentioned it John, do I read correctly that the Glyph is between your FF800 and your laptop? That is, running in series?

It truly is frustrating, as I've come to rely upon and love the unit. I also have to 050Q, and it is a rock.
Just dumb luck I've had the same issue w/ two different units?

FWIW - I redid all the cabling on the back of the rack yesterday, after my last functional session.
Nothing major - just removing cables and taping together those that run to/from the same sets of I/O. Preamps>Patch, Patch>Comps, Comps>Patch, Patch>FF800 etc.
Less clutter, and easier to keep the audio cables away from the power supplies.
I suppose I could have wrenched the firewire cable at the port during the process, but I'm usually pretty careful.

Below is example of cabling efforts, just because I need to feel good about something right now:

bigtree Thu, 04/14/2011 - 17:56

Ah, could be that your RME driver is lost. It sounds like that too! Have you tried to reinstall the driver? It will be in the (if i recall) Device Manager> Human Interface Device> if this is the problem.

If the FF800 driver is not in there, and you see it in your (sounds, video and game controllers), then it is installed and your problem is elsewhere.

try that?

Profile picture for user TheJackAttack

TheJackAttack Fri, 04/15/2011 - 01:09

The two main laptop machines run to the GT050Q first and then to the FF800. The GT051 is just for temp folders and mostly transferring files between computers. One of the machines lives in a SKB Studio Flyer so that rack is put up when not actually on location.

I have many laptops of course. One of my older machines had to be connected 1394b to the FF800 and then 1394a to the GT050Q. I don't know why. I couldn't ever figure it out. This one also wouldn't chain two FF800's together either. My best guess is that Express Card slot (and dual Cardbus slot-Dell D820) was choked down to the Cardbus speed which isn't fast enough to aggregate 800 speed devices.

Profile picture for user thatjeffguy

thatjeffguy Fri, 04/15/2011 - 09:39

Did you try calling RME? I have had nothing but over-the-top personalized service from them every time I have called. You always get a person, they respond to their emails, they are absolutely tops in my book. Now they may or may not have been able to solve your problem over the phone, but it wouldn't surprise me if they offered to FedEx a replacement unit to you, they're that good.
If it's too late for that, then next time you have any problem with an RME unit, call them before doing anything else!
Sorry to hear you've had that kind of trouble. I have an FF 800 as well as a RayDat PCIe card and have been an RME user for nearly a decade. Hope your new unit arrives quickly!

Profile picture for user soapfloats

soapfloats Fri, 04/15/2011 - 22:13

Chris - I don't remember looking specifically in that location for the driver(s). I have them all in a folder on the main drive, on my audio drive, on a flash drive, and on my laptop. That's happened to me before - and w/o internet (I have that now) at the studio, so I'm pretty on top of drivers.
The main concern to me and the rep at Synthax was the fact that the unit wasn't showing up ANYWHERE in device manager. Definitely an issue of communication between the unit and the computer, rather than drivers.

Jeff - I've contacted the local rep and am still waiting for an RA# to send it in.
The phone# I called was in-state, but far away. The return call came from out of state, but luckily, just across the river. If I don't get an RA by Monday, I'll call back and see if I can't drive down and grab something to hold the tide.
I agree - the people at RME and their local reps have done me right the only other time I needed them. Prompt return of calls and such. The fact that it may be 4 days between my first call and receiving an RA# has me concerned, though.

FWIW, I tried running the Firestudio today and remembered quickly why I bought the RME.
All sorts of oddities. Horrible squirrely sounds (kind of like tuning an old radio) in the client's headphones and the recorded track, but not my monitoring.
Slowly stripped the patch, comps, and even outboard pres from the chain until it went away. Also noticed things that looked like digital spikes in the waveforms in the Nuendo, but no audible presence. Checked the spectrum analyzer and it was short bursts around 15Hz. DC offset?
Then random "surges" in the input channels when directly connected to mic. All of these things reminded me of the clocking issues and digital spikes that would periodically occur.
Unfortunately, I KNOW how those things manifest themselves audibly and visually.
More unfortunately, these occurrences did not match what I know.

I can say that these things NEVER happened w/ the RME... which makes it all the more of a bummer that it decided to go silent on me. I never knew how much I needed its stability until it was offline.

Thanks again to everyone for their support and suggestions.
I posted the thread hoping I would get that, but also to get the word out about my particular issues. I care about what I do, and I know RME does as well.
I thought it only fair that I bring up my problems in addition to giving my praise - and what better place than a community that shares my commitment and has more than a few faithful RME users.

bigtree Sat, 04/16/2011 - 00:07

No, I don't mean the driver as in , seeing if it is installed on the C drive, I mean, is the driver loaded so RME can find it via your Device Manager. When the red light is on the FF800, that means its not finding the driver via ther Device Manager. You may need to activate it (again).

Are you able to open up Fireface Settings or TotalMix (toolbar) or where its installed?? If not, you need to reload the FF driver in the Device Manager re my directions.

Follow? Lets hope its that. This happened to me and its confusing until you figure it out.

Profile picture for user soapfloats

soapfloats Sat, 04/16/2011 - 16:02

I'll check that when I get a chance, Chris.
As I recall, there wasn't any instance of the RME driver anywhere in Device Manager.
That's the one thing I hate about the device - no true "install". And w/o a driver to update, I can't seem to get it in there until the RME/Windows tells me it needs it and asks where to look.

bigtree Sat, 04/16/2011 - 16:05

I do believe we have solved the problem. If you don't see it there, it is in the human interface area of the device manager. You will see it there, just load it again, reboot and the FF800 will work.

Profile picture for user TheJackAttack

TheJackAttack Sat, 04/16/2011 - 17:26

That isn't the issue. The issue is there are pins on the firewire port that are broken on the pcb. This would be an identical issue to a broken cable. There is nothing to see in the device manger because there is no connection.

Soap, is Syntax fixing this under warranty?

Profile picture for user djmukilteo

djmukilteo Sat, 04/16/2011 - 17:30

You might want to download the latest FF800 firmware and drivers from the RME website and load those.
It's possible your computer has corrupted them and that's why it's not finding it.
Also something else that can happen is in the Control Panel you might have lost correct settings.
I've seen those get switched to goofy settings like 163456Khz sample rate by other audio software.
The firmware and drivers should always be kept up to date....
Current FF800 driver is: 3.034 for all Windows OS, XP/Vista/7 32/64bit
Current (firmware rev) is: 2.77

bigtree Sat, 04/16/2011 - 18:13

John, did Soap say he see's broken pins or how do you know this? I must have missed that? If so, your are SOL.

Seems odd it happened twice though and for what reason is when I start looking at user area's. Sounds like something else to me but who knows at this point. If you are powered up and you don't see the drivers at all, in either Device Manager area, doesn't sound good.
I've had to re load my drivers more than once and always found them in the Human Interface Devices until I reloaded. Even updating the drivers as [[url=http://[/URL]=""]djmukilteo[/]=""]djmukilteo[/] suggests they get moved in there. We feel for you anyway.

Has this happened to you guys? Re: Human Interface Devices ?

Profile picture for user djmukilteo

djmukilteo Sat, 04/16/2011 - 20:45

I'm using Win7 64bit with Cubase 6 and I only "see" TotalMix and the FF Settings Control Panel icons in the task bar notification area down on the lower right.
If those aren't there and don't get loaded the FF will not be recognized at all.
The FF should have the red LED flashing then as well.
If I go into Cubase like that it will revert to a Windows WDM driver or such and tell me there is no current ASIO driver available.
I have nothing in the HID hardware related to the FF800 in the Device Manager.
I do have RME FF800 listed in the Sound Device controllers and then the TI 1394 OHCI FW bus driver. Those both have to be in there and be correct.

bigtree Sat, 04/16/2011 - 21:06

Exactly on all counts. That's where mine end up too.... after I am forced ! to go the described process, if and when, this happens like Soap is describing. However, bottom right (tool bar) the RME /TotalMix icons can still be there but I am not able to open them if the driver is not activated as I describe. I could be he is missing this but I'd trust John on the final word as he has always been pretty spot on.

Profile picture for user TheJackAttack

TheJackAttack Sun, 04/17/2011 - 00:07

If it is a driver issue, the FF800 will show up as a device without label-possibly a question mark or red X beside it. In Windows Vista or Windows 7 you can hit start and type Device Manager. Look for any device at all that shows as not installed. In all versions of Windows you can get to the Device Manager by going to the Control Panel first and then selecting the Device Manager. I've never had the FF get lost or uninstalled except when I was tweaking some setting or disabling crap. My best guess is that there is a fault at the FF800 firewire port. I had this on one of my 800's that I got from ebay. Syntax repaired it and it has worked flawlessly ever since. I guess my main advantage is that both units are in racks and I never unplug the firewire cables at all ever except at the computer end. If you want to go really nuts you can find and delete the driver in the System 32 folder. If the RME icons are not in the system tray you can also run them manually simply by double clicking them in the program folder.

bigtree Sun, 04/17/2011 - 16:52

I had it wrong. I reproduced what I think can be Soaps probem so please do me the favour and try this:
Go to:

Device manager > Other devices > Unknown devices>Right Click> update driver software > Browse my computer for driver software ( where your RME driver is located (win_fire_3034)

and install it!