Skip to main content

using korg padkontrol with reason 3.0

Hey all,

Last night I bought the Korg padKONTROL to use with reason 3.0. So I got the device installed, opened up a reason test file and set up the device in reason. In addition to the padKONTROL, I have a M-Audio 48e midi keyboard set up for use with reason (this is set up as my master keyboard/device).

So I set the Korg up in reason and locked it to a Redrum module using the Remote Edit Override. but here's the issue. Reason recognizes the two top KNOBS and the X-Y PAD and I have been able to map them to whatever knobs on the module that I want. but none of the PADS (used mostly for perc./drums) are responding. Whenever I hit a pad, reason doesn't even acknowlage that any MIDI data is coming in (but does acknowlage MIDI data is being sent if you turn one of the top knobs or x-y pad). I tried reassigning each pad to a different note (coresponding to the notes [C(1)-G#(1)] that control redrum sounds when I use my 48e keyboard) but that didn't work. I tried changing MIDI channels, but that didn't work either. I've tried to manually map the pad to the "play" button on a Redrum sound using the Remote Edit Override... but it doesn't recognize the pad (as stated eariler, it DOES recognize the two top knobs and the x-y pad and will map to them).

When I go to the Device setup (in edit -> preferences -> midi control surfaces) there is a section where you can "find" your midi device (port) by clicking find and then hitting a button or turning a knob on the interface so the software can tell you what port to select. In this set-up menu, when I click "find" and then hit a PAD (one of the pads that I can't get to map to sound) it recognizes that data was sent and tells me what port to use. In addition, I tested the pads in MIDI-OX and it says that data is being sent (and it controls the wavesynth midi built in to windows fine) so I don't think the pads are faulty. I know that people use the padKONTROL with reason. I mean, the controller came with reason adapted. so I don't think there should be any compatability issues...

so WTF? Anybody have any advise? I really didn't expect to have this much trouble setting it up... everything I have read say how easy it is to set up... but I can't figure it out. Any help would be greatly appreciated!

Tags

x