Having problem on hooking up US-122 and my new system

Discussion in 'Microphones (live or studio)' started by vhvee, May 11, 2006.

  1. vhvee

    vhvee Guest

    Hi, I'm a new buddy here. I need u guys help on the problem that I met.

    I was using my Tascam US-122 with my previous pc system for more than a year. My previous system was, AMD Athlon XP 2500+ with MSI K7N2 Delta motherboard. They worked fine.

    Yesterday, I bought a new pc system, upgrade to AMD Athlon64 3000+ (socket 939) with MSI K8N Neo4 Motherboard. After I installed the US-122, and I found that there are serious noises within any music I play!!

    Then I remove the US-122 and try the motherboard built-in audio system, and it is noiseless!! I suspect that might be a not compatible problem between this US-122 and my new system.

    What do you guys think? Is anybody having this problem? What is the solution?

    Thanks for your help~~
  2. Zoro

    Zoro Guest

    Is your new pc still a 32bit or a 64bit??

  3. tar_tay

    tar_tay Guest


    Its common problem for some people. Generally it is due to low power supply support of USB port connecting your TASCAM. It could be solved by adding up self-powered USB hub and connect TASCAM to that one of the ports of the hub. Make sure leave the rest ports of the hub unused.

    You may find lots of people having same problem as yours at there;


Share This Page