My tube Mic crapped on me today. Please help...

Discussion in 'Microphones' started by sushifish, Dec 2, 2007.

Tags:
  1. sushifish

    sushifish Guest

    Tracking vocals today. Rode K2Tube condenser mic. In the middle of a lyric, the mic pretty much stopped working. Still had a signal but was about one tenth of the volume it should have been at. The singer for some reason pulled the pop-stopper off of the mic right before it crapped out. Checked the tube and it appeared to be fine. Would spit hitting the diaphram cause a short or something? Maybe the cable was jarred...would this cause the problem. It uses a 7 prong female thingy so I didn't have another cable to try. Any suggestions? Any help would be much apprieciated!!! Thanx! -matty
    sushifish.org
     
  2. Cucco

    Cucco Distinguished Member

    Joined:
    Mar 8, 2004
    Location:
    Fredericksburg, VA
    How did you check the tube? This definitely sounds like a tube issue. Is your unit still in warranty? They'll replace it for you if it is.
     
  3. Jbrax

    Jbrax Guest

    I agree sounds like a tube went..
    Those cheap chinese tube they put in there are not prone to long life...If Im right those are 6072 tubes

    I got some nice Military Phillips 6072's off of ebay
    that had much better detail and warmer sounding..

    So look for some NOS or used non -Chinese 6072's
    they will last longer and sound better..
     
  4. Link555

    Link555 Well-Known Member

    Joined:
    Mar 31, 2007
    Location:
    North Vancouver
    http://thetubestore.com/
     

Share This Page