Need help with my firepod! URGENT

Discussion in 'Microphones (live or studio)' started by Cosme, May 24, 2007.

  1. Cosme

    Cosme Guest

    Hi, i've been working for some time now with my presonus firepod, but a few days ago I changed my PC's motherboard and firewire port and now it's not detecting my firepod, I tried with another computer and it didn't work either, tried with another cable and ac adapter and nothing happened, any ideas please!
  2. did it need any key or password to unlock? some kind of way you tripped out the firewire port on the firepod. if it was a hard drive i say change the casing but since your on an interface im guessing its an id problem. software base studios are very picky on switching systems it messes with the data. It would of been better to have upgraded to a new computer and reinstall all your apps to the new computer to see how compatibal the new system is with the old software. There has been too many times i try to upgrade new plugins or some new gear and it changes up my setup completely.
  3. Zoro

    Zoro Guest

    Have you tried reinstalling the firepod drivers?

  4. Cosme

    Cosme Guest


    Yeap I tried installing the drivers again and they didn't work, it's like the firmware in the firepod was changed or something but I don't know when, The firewire port works but it doesn't detect the device (firepod)

Share This Page