NT Bug Fix, any takers??

Discussion in 'Microphones (live or studio)' started by realdynamix, Feb 19, 2003.

  1. realdynamix

    realdynamix Well-Known Member

    Feb 23, 2001
    This one has me baffled. I can't print from LPT1 on my server. IRQ correct, Bios settings correct, Driver for printer correct, all settings correct..but still get message "Error writing to LPT1: Device not ready. Was working, then just quit. Several printers, and drivers tested, same result. No device conflicts, (my computer connection) on this server. No other printers in network. All printers work with respective drivers on 98, eliminating them from problem.

    I get the same error from this port, even with the cable disconnected. Spooler will print to file, but not to port. I removed and reinstalled drivers and ports, and still no luck. Did a search, got 250,000 hit's with the same problem. But, as of yet have not found the "clearly stated, or general accepted fix". Printer see's NT and port, but NT does not see printer???
    NT 4.0, and service pack.
    Any experience with this?
    Many thanks in advance,
  2. AzureCrystal

    AzureCrystal Active Member

    Aug 14, 2001
    Try going into CMOS/BIOS and check the printer port setting, it might be set to something other than EPT/ECC, should NOT be set to normal. I know because I had the same exact problem with my CPU two days ago and I made that change and it worked..... Hope this helps....
  3. realdynamix

    realdynamix Well-Known Member

    Feb 23, 2001
    :) Thanks Stephen, I have tried all, (and saved settings) in bios, no luck :confused: . All other systems operate without any problems. For now, I'll have to print to file, then to floppy to get my reports, have not tried this yet, I hope it will work, it does not allow print to disk A... sheeeesh.
  4. sapplegate

    sapplegate Active Member

    Mar 5, 2001
    You've probably tried all these already, but...

    Open a DOS box/command prompt window. Can you just do a plain command line "COPY <somefile.ext> LPT1:"?

    Have you tried a different printer cable?

    Have you tried the latest service pack (6a)?

    Does your parallel port show up with the correct configuration under WINMSD.EXE?

    MS's support site points to hardware. Maybe the parallel port on the MB is gone? Make a DOS boot floppy and boot from it, then try "COPY <somefileonfloppy.ext> PRN".
  5. realdynamix

    realdynamix Well-Known Member

    Feb 23, 2001
    :) Thanks Scott, tried it all, no DOS, System initializes from NT boot discs. But have tried direct command from the REGEDIT line, same story. All configs (viewed in diagnostics) are correct, not sure if that is like the winmsd.exe that you mentioned.

    Paraport address correct, and running in auto. Spooler running. I have service pack 6, but not sure about the "a" designation. Funny thing is, I have another NT computer in the workgroup portion that does the same thing on it's own LPT1, (in my computer), Got the same result in it's LPT1. The printer port worked for a short time then stopped, in my searches on the net, I have found this very condition with 1000s of people. Have changed cables, etc. Even had an NT tech try about 8 hours (remote) going through the system :d: .
    Many thanks,
  6. mfilter

    mfilter Guest

    Yes, I have dealt with a couple NT machines that just decided they didnt want to print anymore :confused:

    When all else has failed, I have had luck deleting any references to the print driver in the registry, namely

    HKEY_LOCAL_MACHINESYSTEMCurrentControlSetHardwareProfilesCurrentSystemCurrentControlSetControlPrintPrinters(your printer)

    (Thats in win2k but I think its the same in NT4)

    and then reinstall the printer.

    good luck,

  7. realdynamix

    realdynamix Well-Known Member

    Feb 23, 2001
    :w: Thank you all for your help, I did find a work around, but the software is "raster something" print (from proprietary software) and when printing to file/disk to a free computer it doesn't look as pretty. Thanks Michael! I'll give it a try Monday. Have a good one!
  8. Opus2000

    Opus2000 Well-Known Member

    Apr 7, 2001
    Hope I'm not too late on this one. I do apologize for not responding as I've been in moving hell and work hell lately.
    Being the IT guy at Apogee I've had my fair share of printing problems with some of the workstations in the office.
    Ever since changing the Novell server to a Win2k server things got a little screwey! Basically the printers were normally allocated from a Linux machine running NetMax(god awful program I tell you!)
    Sometimes it's the driver you load that can cause this. The server machine that has the printer may not want to have a Post Script driver installed on it. It really depends on what type of printer it is too.
    Obviously if you are hooking it up to the parellel port it's not equipped with a NIC card for true TCP/IP networking.
    At that point it's a file sharing setup directly from the system.
    I don't know NT that well but Win2k Server and WinXp both have a portable Serial number service that can mess with the parellel port settings!
    Check into that.
    Try the driver change first
  • AT5047

    The New AT5047 Premier Studio Microphone Purity Transformed

Share This Page