PC based DAW audio skips (Ableton)

Discussion in 'Computing' started by Molotov256, Jul 12, 2011.

  1. Molotov256

    Molotov256 Active Member

    Dec 3, 2010
    Not sure if this is an appropriate forum to post about these kinds of problems, so move or delete me as needed. I'm just banging my head against the wall trying to record some drums into a multitrack recording I'm working on with my band.

    Computer: Althlon 2 X2 3.3GHz, 6Gb RAM, 1TB SATA drive, Win 7 64.
    Interface: Presonus Firestudio Project
    DAW: Ableton Live 8

    I'm not sure if I should give up on Ableton, the Firestudio Project, or both. We have 7 tracks running right now in the Ableton Project, 2 for guitar, 2 for bass, 1 for Vox, and one for a Click Track. I am recording the drums last and am using a 5 Mic setup, each mic routed to it's own input and track. I have no FX or VST plugins running whatsoever.

    My problem is the audio playback keeps skipping while I'm trying to record to it - it will essentially take a quick rest for a second or less, and then resume as if nothing happened - tempo remains the same, click track keeps going, only it totally throws off my drumming and I have to essentially scrap the track and start over. It's making this whole setup a pretty useless recording tool.

    How can I fix this playback skipping in Ableton? Here's what I have already tried that hasn't eliminated the glitchy audio playback:

    I have adjusted the buffer size of my Firestudio (and Ableton) to 1028, 512, 256, 128, and 64

    I have copied the project I am working on to the local Hard Disk

    I have worked on the project from an external USB 2.0 Hard Disk (just to try it)

    I have loaded samples into RAM manually in Ableton.

    I have restarted Ableton and the PC and the Firestudio project.

    Any help would be most appreciated. I'm pretty close to selling all this crap and just getting one of those self contained units because I cannot deal with this godawful workflow.
  2. Guelph_Guy

    Guelph_Guy Active Member

    Sep 2, 2013
    Ontario Canada
    On your USB storage , what's the speed of the hard drive ? Some of those external drives are for archival purposes and run at 5400 rpm , these maybe to slow to process the data from multiple tracks. I would confirm your external drive speed by checking the manufacturer...I would do this with the internal drive as well..

    I can't comment on the memory size as I've never gad a computer under 16 GBytes ... I am running Ableton 9.5 and a push... but recently switched to Windows 10
  3. DonnyThompson

    DonnyThompson Distinguished Member

    Nov 25, 2012
    Akron/Cleveland, OH
    Home Page:
    First of all, I need to say that I'm not an Ableton guy... so you might have a much better handle on it than I.

    Normally, I would point you towards the RAM buffer as the most common culprit in cases like these with those symptoms you mentioned, but you mentioned already trying different buffer settings...

    Did you really mean 6 gb of RAM, or did you mean to type 16?

    If this wasn't a typo, and you really are working with 6gb, then that's a bit shy on the RAM side, ( also, "6" is a little odd in how RAM is normally installed... usually it's in numbers divisible by 4) ... although I'm not sure that upping that by only a few gig to 8 would help the situation entirely - we need someone with more computer knowledge to weigh in on that part.

    As GuelphGuy mentioned, HDD speed could come into play, in that perhaps the system is trying to read and write data faster than what your current HDD speed allows...

    Some questions:

    Are you new to this program ( Ableton), or new to DAW recording all the way around?
    Is your version of Ableton 32 or 64 bit?
    You mention having trouble when attempting to record 5 tracks at one time.... Have you ever tried recording this many tracks at one time before, using this exact same hardware and OS, and been successful with any other DAW platform?
    Have you successfully recorded to Ableton when recording only 1 or 2 tracks at one time?
    Have you tried using another DAW platform, just to make sure that it's not something glitchy in Ableton? ( just to try and narrow this down), something like the free version of Presonus S1 ( this program might have even come as a freebie disk with your Firestudio I/O, if it didn't, you can DL the free trial series version)...

    Have you visited the Presonus website support/downloads page and made sure that all drivers ( and firmware) for your Firestudio are current, up to date?
    (Presonus has made some recent updates, BTW. I installed an update package for my 1818VSL just a few days ago, and it's been almost two years since I installed the original drivers, so they do continually release updates, even for older devices; while I can't say for sure that your Firestudio was included in these updates, it's probably worth a look to make sure either way...)


    Have you done the same thing with your version of Ableton, and checked for program updates, bug fixes, patch downloads?

    If you are able to record 5 tracks at a time successfully using your Firestudio I/O and on another DAW program (like Studio One), have you contacted Ableton support?

    I notice that they are up to version 9 now... but I also noticed that there were several different bug fixes and patches to 8 over the past few years as well... I've seen versions described as 8.2, 8.4...

    Have you gone into windows control panel, and made sure that the Presonus is set ( checked) as the default audio device, and that all other audio devices on your system are checked as disabled? ( these could be audio devices like built-in SoundBlaster, Realtek, Conexant cards, etc., or any other sound cards resident on your system, that normally come with a store-bought PC, for things like gaming and internet audio)
    Have you made any recent changes to your PC... new software, new hardware, a recent system/OS update, Virus protection software...

    All of the above is "process of elimination" - and with today's technology, we have to accept the fact that not everything is always "install and instantly work" or truly "plug and play", and that we have to occasionally jump through hoops like these when issues arise. ;)

Share This Page