Recording skips like a CD

Discussion in 'Microphones (live or studio)' started by CrackerBrand, Mar 21, 2008.

  1. CrackerBrand

    CrackerBrand Guest

    Hello all, haven't posted in a while.
    Last time I was building a recording studio which is now done..
    and I thought that was going to be the frustrating part ;D

    anyway, i've been reading the site, and Big Thanks to all of you taking time out of your busy lives to help us struggling.. It's a life saver, and for those of us who live out in rural areas, it's virtually our only help.. Trust me on that one!

    I'm using:
    Mackie Onyx Satellite Firewire recording module
    AT2041SP, which is a studio pack containing AT2020 and AT2021 mikes. (TAKE NOTE THOSE LOOKING FOR BUDGET CONDENSERS, THESE ARE AMAZING FOR THE PRICE)
    Tracktion 2
    P4 3.0Ghz cpu with 2.25Gb of ram
    old donated amplifer
    Some 10" Radioshack Montiors (Don't make fun)

    Anyways.. the problem I'm running into, is after I make a recording, and play it back, I'll have skips in the playback
    Not empty gaps where the sound should be, just as if i had highlighted half second fragments, and the program joined the spaces together
    like a scratched CD

    Originally I thought maybe it was the amp, as it was older, and it was just during playback, but lo and behold, after burning it, it skipped in the car too

    Also I have noticed when I play a file outside of recording.. say an mp3 of the upcoming Counting Crows album, or midi notes from the ear trainer on or just about anything
    there will be pops.. cut outs.. right at the beginnging of the playing, and occasionally during the middle.. (i use the onyx for all playback, as i have no room for a soundcard in my tower thanks to this thing

    I tried everything i could think of.. eventually i formatted, and installed TinyXp Platinum Edition 2, in hopes that i just had too many processes built up in resident memory, as it had been a while since the last format

    but nope.... still clips..

    been struggling for a couple months now, and any help would be appreciated as time isn't a big luxury for me.. i work full time, and i'm taking 18 credit hours (music major of course)

    any thoughts/suggestions?
  2. pr0gr4m

    pr0gr4m Well-Known Member

    Feb 9, 2005
    South Florida
    Home Page:
    Are you are using ASIO drivers for the Satellite? If so, make sure they are updated. If not use them.

    As far as recording goes...are you recording to the same hard drive that your program is running from? Or to put it a better way, if Tracktion is installed on drive C are you recording/storing your audio to drive C? That's a no no. It doesn't always cause problem, but it does most of the time.

    Check your audio buffer size and increase it to the max and see if you have the same problem. If not, then you'll need to test out the different settings there to find one that works best for you.

    To have a cooler like that, you've probably got a nice video card which means you've probably got games and all sorts of other things installed on the computer. Check for anything running in the background, including antivirus programs, firewalls, wireless auto detectors, etc. Kill 'em All.
  3. CrackerBrand

    CrackerBrand Guest

    Well as I'm reading it ASIO should be built into Satellite Drivers

    from the site
    " Tracktion 2 music production software with Mackie Mixing and Mastering tools, so you can go from initial idea to final CD. (Of course, with WDM, GSIF, ASIO and Core Audio drivers, Onyx Satellite can also be used with most major audio software on Mac or PC.) "

    And yes! I have been recording to the same HDD that the program is on! I always assumed putting it on another drive would use too many system resources, trying to run from one and write to another... good idea
    What about using a partition? would that be as effective? There's only one hard drive in my tower.. and I know writing to my External would be a terrible idea :D

    I do have a nice video card, but I have one or two games..<-- Doom 2 (1994, it's classic and about 8 megs) ;) (well it used to be a nice card, bought it at $600, now it's valued at about 100 i think) but I don't have as much as you might think..
    and I always run "EndItAll2" before starting a session

    The thing that gets me, is I have recorded in the past, and never encountered this problem :\

    I'll wait to hear your reply on the partition before I format again :p
  4. CrackerBrand

    CrackerBrand Guest

    I was trying to experiment, and figure out the cause of my problem, and i was going to do a test recording.. when i notice.. the pops were occuring BEFORE i actually started recording, I was just trying to find the sweet spot for my guitar, listening to the INPUT, and BAM, there they were.. now i'm really baffled
  5. CrackerBrand

    CrackerBrand Guest

    update #2
    after some more analysis
    The skipping frequency is the same, whether recording, just listening, watching an mpg, everything
  6. moisiss

    moisiss Active Member

    Sep 19, 2006
    New York, NY
    Home Page:
    Sounds like an IRQ problem to me....

    What are you plugging the Firewire (from the Mackie) into? If it's onboard... I don't know what to do (possibly invest in a PCI firewire card with a good chipset.. like Texas Instruments).... but if it is a PCI Firewire card, make sure that it isn't sharing an IRQ with something else (or that anything it is sharing an IRQ with is disabled). I was running into the same sort of problem with my Firepod (crackles and popping) and found out that it (my PCI Firewire card) was sharing an IRQ with my wireless PCI card. So I then disabled the wireless card when I was doing any audio work and the problem was solved.

    Don't partition your drive... it won't be any better. Just get a new internal drive (about 250GB for $70.00 these days). That said, I recorded to my system drive for a LONG time and had 0 problems.... I didn't even realize that there was a problem doing that until I read about it a while ago on this forum!

    Also, for the ASIO stuff, I know for the firepod I have to choose the firepod ASIO drivers in my recording program (I use Cubase LE)... so maybe check your audio preferences in Tracktion 2 and make sure you are using your Mackies ASIO drivers?
  7. CrackerBrand

    CrackerBrand Guest

    I wish it were PCI now :p
    haha, nope. It is onboard :) :\

    I'll work on getting another internal drive. Thankfully I work at an electronics store and can get things at whole sale. I may be able to get a smaller one for free (just to test out the issue and get me by until I can afford better one)

    Yes, I definitely have been using the satellite's ASIO drivers. While I wouldn't dare refer to myself as experienced, I'm not exactly "uber-noobie".. I've been trying to record for about 8 years on and off.. so when I run into a problem, unless I'm having an ADD attack, it's usually a bizarre one
    I will try to discover an IRQ conflict and go from there. Thanks for your input, extremely helpful!

    One last thing, would it be worth the effort to try to track down a replacement firewire cable? Or is that pretty much a non-issue..

    Normally I wouldn't have even asked that.. I'd just grab a new one.. but this semester money is extremely thin... well.. time to go heat some ramen.. :) thanks again
  8. basilbowman

    basilbowman Guest

    Firewire cable? I wouldn't, I mean, you could, but it sounds like this [possible] IRQ conflict is more likely, and is easier to check up on. I'd play with that first. Another thing that might be worth trying is a complete wipe of your current ASIO drivers and reinstalling them, and maybe putting the ones you've got back on seeing if you can borrow another interface to check real quick to see if the problem is repeated with that interface. That way, if it is you know it's a computer problem, if it isn't than it's an interface/driver/relationship between the two problem. Might be useful to know...
  9. Cucco

    Cucco Distinguished Member

    Mar 8, 2004
    Tacoma, WA
    Try disabling devices that you are not using -
    WiFi cards are notoriously bad for causing this kind of thing as are memory card readers, extra FW ports, etc.
  10. mark02131

    mark02131 Active Member

    Jun 9, 2004
    Boston, MA
    unplug your internet connection, I had an Ethernet card that did that to me. As soon as I unplugged the internet cable it stopped.
  11. CrackerBrand

    CrackerBrand Guest


    ok, im pretty exhausted.. im running out of leads to follow
    Another update however, i have noticed now that when i burn audio cds.. there is a horrible swishy staticy sound that ends up on the final product.
    I originally thought the burner was bad, so i replaced that..
    no dice :(

    any chance it might be the operating systems fault? (tinyxp)

    or perhaps the firewire issue and the cd burning issues are coincidence?
  12. hueseph

    hueseph Well-Known Member

    Oct 31, 2005
    Vancouver, BC, Canada
    Just a couple of things to note. If you have registered your Satellite with Mackie, there is a firmware update. Also you should be able to download and install Tracktion 3 and your current license will transfer over. Hassle free.

    Just curious about TinyXp because it intrigues me. Are there any legal issues with this? I want it.
  13. Space

    Space Well-Known Member

    Jun 26, 2007
    That is a lot of the issue. You simply cannot isolate a recurring conflict by doing this type of hack.

    The other is most likely the graphics card and that cooling refrigerator.

    Still yet another is the tinyxp os.

    You have a gaming system you want to record audio on, you have to choose one or the other.
  14. Codemonkey

    Codemonkey Well-Known Member

    Dec 11, 2007
    Scotland, UK
    To anyone else reading this, you CAN do both, but with limited success.
    I got 6 tracks down for a 45 min and a 90min spell at a concert recently, using my All-for-one box. Not a single skip in any track, although 2 I wasnt fussed about, just reference feeds from the Mains.
    Granted though, I'm not trying anything difficult (only 44.1/16)
  15. Space

    Space Well-Known Member

    Jun 26, 2007
    Are you saying you have the same type system this person has?
  16. CrackerBrand

    CrackerBrand Guest

    >>You have a gaming system you want to record audio on, you have to choose one or the other.<<

    got it.. so you can only have an system for recording audio if you use your factory integrated graphics card..
    thats pretty ^#$%ed up, because a lot of people like to record with a dual monitor setup, hardly standard.. i hope you feel better now that you've vented though..

    strange because ive recorded fine with the system for at least 3 years prior
    maybe you're just wrong.

    </ends annoyed tone>

    at any rate.. back to useful information, i have updated my firmware, and i did upgrade to tracktion 3, but it was rather buggy (at least while using the waves mercury bundle) so i went back to 2

    all before my skipping/dropout/cutout problem whatever you wanted to call it appeared

    I have also switched firewire ports
    and removed my wireless card (which i previously just tried disabling)
    i also checked for IRQ conflicts.. none to be found
  17. CrackerBrand

    CrackerBrand Guest

    Oh, and even if it were a "gaming computer".. most "gaming computers" are capable of playing back .wav files without skips and drops, your ass-umption would be correct if i were only having the problems during recording sessions
  18. hueseph

    hueseph Well-Known Member

    Oct 31, 2005
    Vancouver, BC, Canada
    Does anything in this thread help?:

  19. Space

    Space Well-Known Member

    Jun 26, 2007
  20. CrackerBrand

    CrackerBrand Guest

    it turns out there was a compatibility issue with onyx gear and XP SP2 (which is what tinyxp is based off of) someone (besides mackie) was kind enough to make a guide for installing the XP1 firewire drivers over the XP2 drivers..

    the issue is, something in SP2 turns down the voltage of the firewire ports... lame.. and microsoft has a HOTFIX, which i read in other forums did no good.. but i was running out of options.. so i tried it.. and it didnt work

    i again formatted and used the basic XP2 install that came with the computer, and STILL had the same problem..

    however this user made patch/guide did the trick.. since last posting, im glad to finally have this behind me.. if anyone else has mackie hardware and a skip issue i'll be glad to dig up that link again.. i was about to throw my computer out of a window..
    thanks to everyone who helped

Share This Page