Saffire Pro 40 help (no output from device)

Discussion in 'Microphones (live or studio)' started by Unregistered, Jan 22, 2011.

  1. Unregistered

    Unregistered Guest


    I am having issues with my Saffire Pro 40 which I recently purchased. I am not getting any input or output from the unit. The MixControl loads the preset levels and says "Connected" or "In Use" for the Firewire connection but does not show any levels active on the fader (as I am not getting any input). I am running on a HP TX2500Z 2.2GHz dualcore laptop with Windows 7 64 bit. I am running the legacy firewire driver on my IEEE1394 compliant device. I have optimized the computer for audio use.

    The "FW Active" light is blinking on and off in the front of the unit and when going under sound in Control Panel to view the microphone it just flashes up to peak once every 5 seconds or so.

    I am inputting to the computer via a Firewire B 34mm ExpressCard.

    The device worked once before, but is not working now. Even when it worked before, the Saffire MixControl did not.

    The MixControl runs very slow and sluggish and this try came up with a message: "This version of Saffire MixControl is out of date with respect to the connected device. Continuing may make your Saffire inoperable, and the program will now close. Please download the latest version of Saffire MixControl from"

    I have MixConrol 2.2 installed (the latest version according to the support site).

    I tried the unit on a MacBook Pro and it ran fine with MixControl.

    Please assist however you can. I am lost at this point.


  2. Gthor48

    Gthor48 Active Member

    Aug 18, 2010
    Saint John, New Brunswick, Canada
    I am wondering if the drivers are what they claim. I have a Liquid Saffire 56 with Mix Control 2.2and it is very buggy. In and out of sessions sometimes means loss of routing, I could not get the headphone feed to work. I have a Eleven Rack in through SPDIF and a ART Voice Channel connected through the ADAT.Mix Control 2.2 and Pro Tools 9.0.1 Mac OSX 10.6.6. I will be troubleshooting extensively tomorrow. I will let you know what I find. It apply to your windows problem if it is entirely on the Saffire side.
  • AT5047

    The New AT5047 Premier Studio Microphone Purity Transformed

Share This Page