shared library error message when launching PT's HD

Discussion in 'Mixing & Song Critique' started by JimB, Jan 29, 2011.

  • AT5047

    The New AT5047 Premier Studio Microphone Purity Transformed

  1. JimB

    JimB Member

    Jan 29, 2011

    I am trying to open a Pro Tools session but keep getting this error message:

    shared library error. "3<Pro Tools PPC dbg><DAE><DSI><DsiWriteHostRegister>"

    I have Pro Tools HD 6.9.2 on a dual 2.7 GHz Power PC GS, 6 GB DDR SDRAM, running on OS X 4.8 . With 2 internal hard drives.

    What happened was all was running fine for years, until a few days ago I tried to load Pro Tools 8 (Digidesign install disk from the studio I work at). The disk wouldn't read, so I upgraded the OS to OS X 4.11 & this is when it seemed everything went nuts (computer wouldn't boot, had to boot from install disk & switch boot drives, in which the computer turned on with no problem.

    After doing some reading on the Avid forums, I reset the PRam & NVRAM, did a zero erase on the boot drive after backing it up & repaired disk permissions from the 'disk utility' located in the install disk menu. After this, when I tried to launch
    Pro Tools, I received the 'unable to locate Digidesign Hardware' error message that wouldn't go away even tho' everything was on, connected & working fine previously.

    I then uninstalled & re-installed
    Pro Tools from the original install disk & now I'm receiving the 'shared library error' message.

    I know this sounds quite complicated, but if anyone here has experience with this type of message (of which I can find NOTHING about it on the Avid support site or forum) I would greatly appreciate your assistance.

  2. TheJackAttack

    TheJackAttack Distinguished Member

    Mar 20, 2008
    currently Billings
    Avid - Pro Tools LE for Mac OS X Compatibility & Upgrade Information

    PT is the most finicky DAW on the market for hardware/operating system compatibility. I'll just say you should have double checked before trying to load PT8 onto your machine. My best guess is that you are going to have to upgrade your OS or uninstall PT completely, do your reset options, and only then try a reinstall. Again:
    -uninstall PT (both versions). Delete ANY folders left over on the hard drive.
    -reset your PRam etc.
    -check the compatibility of your OS with the version of PT you want to run.
    -install PT. If necessary you may have to boot the Mac into an older version of Mac OS compatible with the PT version. READ THE CHART LINKED ABOVE!!!

Share This Page