Tascam TSR 8 won't play but will forward and rewind

Discussion in 'Mixing & Song Critique' started by tigali, Jun 6, 2010.

  • AT5047

    The New AT5047 Premier Studio Microphone Purity Transformed

  1. tigali

    tigali Guest

    Any ideas? I just bought this second hand and I was told the only problem was a perished pinch roller. I replaced the pinch roller and fired it up for the first time yesterday and it won't play. It forwards and rewinds and stops without problem. The display is perfect and if I manually roll the tape across the heads the meters register the material but it won't play. I'd like to exhaust all avenues before going back and accusing the guy of selling me a dud.

    Apologies if this is the wrong forum, if it should be in DIY maybe the moderators can move it there? Thanks.
  2. moonbaby

    moonbaby Mmmmmm Well-Known Member

    Feb 23, 2005
    Are you SURE that you have the tape routed correctly through the arms and pinch rollers, etc.?
  3. tigali

    tigali Guest

    Yes, thanks. Turned out I had to open up the front panel and re-attach a belt that had fallen off a roller. The problem was solved for about a minute when it appears we had a power surge (the one time I plugged a piece of kit straight into the wall and not the surge protected extension) and it seems to have blown a fuse or something. The transport controls aren't engaging and a light in the same section connected to a selector is no longer lighting. All other areas of the display and function lights are working so it's not a major issue but something is definitely blown that had been working just a few minutes before. Now it won't forward, rewind or play but I'm pretty sure the main non-playing problem is solved. Now it's an electrical issue. Thanks for your reply tho.

Share This Page