tascam us 122 latency issue

Discussion in 'Converters / Interfaces' started by ffernandez, Nov 15, 2005.

  1. ffernandez

    ffernandez Guest

    I'm experiencing some clicks during playback using a tascam us 122 with Nuendo 3 (setup on my signature). The project only contains midi with some vsti's (processor working at 50% according to nuendo meter)
    I have followed the tascam OS tweak document, some others too, but clicks are still there. Any ideas of how can I workaround this?
    Is latency a common issue with tascam us 122?
    I know that is completely different scenario, but on my iBook G4 1GHz, 768MB Ram used to work perfectly with ableton live 4 and cubase 1.6.
  2. tar_tay

    tar_tay Guest


    Get the help from there buddy.
  3. jake88

    jake88 Guest

    some things you can try:

    do disk cleanups on all your hard drives

    go to start - run - type %temp%
    this opens your temporary files - delete all of them

    you may have to uninstall and reinstall the drivers (from tascam website - version 3.30 is the latest i think)

    when you install the drivers follow their instructions exactly

    close antivirus software and all non-needed processes when you do your music thing - i usually disable my network connection when i have to disable antivirus

    make sure you have the latest windows updates

    try changing from 44.1 to 48 khz in your program - that usually helps with my us-122

    one time - none of these worked for me - and i reinstalled xp completely and that solved
  4. DrivenOne

    DrivenOne Guest

    Tascam US 122 latency

    I don't know what software you're using, but when I 1st hooked up my 122 I had the same problem. As it turned out, the software I was using (the Cubase LE that came with it) was set to use a windows ASIO driver. I changed it to use the US-122 ASIO driver and then went to the US_122's contol panel and dropped its buffer to 512. No more latency!

    Also on the clicks and pops, I also had the same problem after getting the latency down. I run this on a brand new Toshiba Laptop. So far, the only way that I've been able to overcome it is by setting everything to use 16bit 44,100 resolution. I'm still working on it though. Will post more if I'm able to bump things back up to 24 bit 48,000 without problems.

    Hope this helps.

Share This Page