TASCAM US-122L Problem.. ugh... any help?

Discussion in 'Microphones (live or studio)' started by Locke, Jan 22, 2008.

  • AT5047

    The New AT5047 Premier Studio Microphone Purity Transformed

  1. Locke

    Locke Guest

    Right so I got myself a TASCAM US-122L audio and MIDI interface to do some recordings. It was working fine for a week, now all of a sudden, it doesn't seem to be working... kinda. It's a rather strange problem.

    It works as an output, like a soundcard (for example, to play songs on iTunes with) but as soon as I load up Cubase, FL Studio, or Live v7 with it active in the USB port, as soon as it gets to activating the ASIO driver my entire screen goes completely blank and the laptop doesn't respond. The HDD is still going, the screen is on, it's just blank. The programs will load up fine when the TASCAM is disabled, but as soon as I enable it or insert the USB cable with these programs running , I get the blank screen.

    I've never encountered this problem before, I'm just trying to think what the root of the problem is. I've tried reinstalling the drivers, reinstalling the audio programs, deleting VST instruments, it still doesn't work. Could it be conflicting with something? I haven't tried disabling my internal soundcard but I don't see how that will help, plus it could be corrupt ASIO drivers, or maybe, the thing's just a dud and I'll have to exchange it, but it was working before so that's unlikely... I guess.

    Any ideas on what's wrong?
  2. hueseph

    hueseph Well-Known Member

    Oct 31, 2005
    Vancouver, BC, Canada
    Have you tried downloading the latest drivers from Tascams site? Just curious. Are you using Vista?

Share This Page