Trident-65 qestion.......

Discussion in 'Consoles / Control Surfaces' started by Mad John, Apr 2, 2003.

  1. Mad John

    Mad John Active Member

    Joined:
    Nov 25, 2001
    I have a used Trident -65 that I got last year and I am just about to get a tech to look at it.

    A few times it did something that concerned me and recently it has been doing this more often:

    The EQ lights will go out with the green solo light in the center of the board dimly lit.

    I have been able to correct the problem by turning the console off for a few minutes and the EQ lights would come back on and the green light would be off. :mad:
     
  2. Twist Turner

    Twist Turner Guest

    I dont' have a Series 65 anymore so I dont' have a manual, but it sounds like it might be a logic thing, is there a logic chip or chips in the master module? Maybe try reseating it, or replacing it.
     
  3. Bo Hansén

    Bo Hansén Active Member

    Joined:
    Apr 25, 2003
    Location:
    Sweden
    Home Page:
    Hi John,
    I have take a look in S-65 servicemanual, and the EQ on/off LED have a mechanical on/off switching in the EQ in/out switch, so there is no logic fault.
    But I suspect there is a fault in +5 Volts feeeding to the modules or if the 5 Volt regulator in power supply have a temperature problem. (+5 Volt = LED and logic supply)
    Have you notice if other LED are cut off when the problem is coming upp.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice