Very Close

Discussion in 'Recording' started by sibleypeck, Mar 22, 2006.

  1. sibleypeck

    sibleypeck Guest

    I have spent two months trying to get my system to work properly. I've read and followed instructions. I've optimized my OS. I've tried different FireWire cards. I've removed the sound card from the CPU. I've read. I've surfed. I've adjusted. I've agonized. And now I'm ready to kill myself. I won't do it, of course, but I feel like I want to.

    I'm a guy who analyzes to the nth degree. I avoid frying pans. I don't jump where there might be fire. I consider. I plan. I theorize. I test. I simulate. Then I reconsider. Then retest. And now I'm ready to, well, you know.

    I don't even want to win the lottery any more. I just want my system to work. I want to record. I want to play back. That's all. I don't want to kill myself. But I'm gettin' close.

  2. AudioGaff

    AudioGaff Well-Known Member

    Feb 23, 2001
    Silicon Valley
    I'd say before you do something drastic or that you'll regret, that you first share the details of your system and your problem. But you also have to accept the fact that not all problems can be resolved in some specific DAW systems, and it can sometimes require major changes to the current hardware and/or software.
  3. Thomas W. Bethel

    Thomas W. Bethel Distinguished Member

    Dec 12, 2001
    Oberlin, OH
    Home Page:
    The other thing is that you may have a problem with your MOBO that you are not even aware of or you may have some other hardware problem. A couple of years ago we had a machine that would go flaky every once in a while. It would shut down at random times and was a mess. We finally traced it down to a bad power supply, replaced the power supply and BINGO no more problems. Turned out that the power supply had some internal problems caused by component failure and was shutting down when certain circumstances happened inside the supply. Modern computers are wonderful but they can have all sorts of problems. I just repaired a friends computer and it turned out to be a problem with the memory sticks not being properly seated. I would check over all your connections, rule out the obvious and start doing some trouble shooting based on logic.

    Best of luck

    Some info on your computer would help a lot,
  4. sibleypeck

    sibleypeck Guest

    That sounds reasonable.

    Dell Optiplex GX270 small desktop model
    2.6 GHz
    80 GB hard drive
    1 GB RAM
    Windows XP SP2
    Cubase LE
    Tascam FW-1884
    SIIG 3-Port PCI i/e FireWire card
    SoundBlaster LIVE!
    USB peripherals including printers, hub, card reader.

    This computer is not dedicated solely to audio processing. I use it for everything, including iTunes and internet.

    The problem existed prior to adding two external USB drives.

    In both of my only two Cubase projects, I get audio dropouts at FW-1884 Control Panel Audio Latency settings lower than 2048. Typically on playback of recorded audio I will hear 1/2 to 1 second of audio, followed by 30 to 35 seconds of silence, followed by 1/2 to 1 second of audio, etc., etc.

    At a setting of 2048, I get occasional crackling sounds of very short duration - fractions of a second.

    Cubase responses to 1884 controls are delayed, and the Cubase tracking bar may or may not hesitate as it moves along in the project window.

    I have followed recommendations found on various forums, including:
    Optimizing Windows
    Following all setup instructions in the manuals
    Checking all the settings in the FW-1884 Control Panel
    Installing the latest ASIO drivers
    Changing FireWire cards
    Disconnecting the SB LIVE!
    Using a shorter FireWire cable
    to name a few.

    I do not have an electronics background, am moderately intelligent, and do not always notice the obvious.

    By the way, it was good of you to respond.
  5. Thomas W. Bethel

    Thomas W. Bethel Distinguished Member

    Dec 12, 2001
    Oberlin, OH
    Home Page:
    Well it sounds like your firewire device is not keeping up with your computer. There are many things that could be causing this. We recently had to switch to Granite firewire cables for our video studio and they helped a lot. Our computers are in a machine room and we had about 15 feet of, what we thought was good firewire cable, connecting up the firewire in the computer to our Canopus interface. The Granite cables seem to cure the problem. I would do things in a logical order.

    Get a good quality firewire cable and substitute it for the one you have, If that does not help the problem, then try a different Firewire card (there are differences in firewire cards and you want one that subscribes to the Texas Instrument protocol. (see here Some devices are more tolerant than others of problems. There is a new firewire standard the "b" version which allows for higher speeds, I would also contact TASCAM to see if they have seen this problem. I would also look at your Device Manager in your system in the control panel to see if you have some IRQ conflicts with your firewire card and what those conflicts are. If you open your device manager and see anything with a red symbol on it check out what the problem is.

    The replies you have gotten so far are all valid. You need to be very systematic in your trouble shooting. I would get a BIG yellow pad and write down every step as you try it ( this keeps you from going over and over the same problem and may lead to some interesting discoveries along the way.) I am assuming that you have your program on the C: Drive and are using one of the USB drives for your audio files? If that is the case is the external USB drive USB 1 or USB 2? If it is USB 1 there maybe a bottleneck at that point. If you are writing back to drive C: that can also cause problems. Is you internal drive drives IDE or SATA?The other thing would be to check and see what other programs are running in the background. Sometimes programs going out to check the status of the printer or card reader can interfere with the audio stream. I have also seen problems when the video card is on the same IRQ as the firewire card. There are SOOOOOOOOOOO! many things this could be it will take a good detective to find the solution.

    Best of luck and as you trouble shoot let us know what you are finding.
  6. sibleypeck

    sibleypeck Guest

    I have tried different FireWire cables and am using a good quality one now. I have tried different FireWire cards, and the one I am using now is TI OHCI compliant. I have not tried a 1398b cable because the FW-1884 is limited to 400mbs, as is the SIIG 3-Port PCI i/e. I have tried to contact Tascam. Tascam U.S. won't acknowledge my emails; Tascam Germany tells me to contact Tascam U.S. There are no red symbols in the Device Manager.

    I have the program and audio files on the c: drive as I've just recently added the external drives, both of which are USB 2.0. The internal drive is an 80 GB EIDE, 7200 RPM, ATA/100. The problem occurs with no other programs running in the background.

    This is what I see in System Information:


    IRQ 0 System timer OK
    IRQ 1 Easy Internet Keyboard OK
    IRQ 3 Intel(R) 82801EB SMBus Controller - 24D3 OK
    IRQ 4 Communications Port (COM1) OK
    IRQ 6 Standard floppy disk controller OK
    IRQ 8 System CMOS/real time clock OK
    IRQ 9 Microsoft ACPI-Compliant System OK
    IRQ 12 Logitech-compatible Mouse PS/2 OK
    IRQ 13 Numeric data processor OK
    IRQ 14 Primary IDE Channel OK
    IRQ 15 Secondary IDE Channel OK
    IRQ 16 NVIDIA GeForce4 MX 440 with AGP8X OK
    IRQ 16 Intel(R) 82801EB USB Universal Host Controller - 24D2 OK
    IRQ 16 Intel(R) 82801EB USB Universal Host Controller - 24DE OK
    IRQ 16 Creative SB Live! Series (WDM) OK
    IRQ 17 Texas Instruments OHCI Compliant IEEE 1394 Host Controller OK
    IRQ 18 Intel(R) 82801EB USB Universal Host Controller - 24D7 OK
    IRQ 18 Intel(R) PRO/1000 MT Network Connection OK
    IRQ 18 Intel(R) 82801EB Ultra ATA Storage Controllers OK
    IRQ 19 Intel(R) 82801EB USB Universal Host Controller - 24D4 OK
    IRQ 23 Standard Enhanced PCI to USB Host Controller OK


    Memory Address 0xF0000000-0xF7FFFFFF Intel(R) 82865G\PE\P Processor to AGP Controller – 2571
    Memory Address 0xF0000000-0xF7FFFFFF NVIDIA GeForce4 MX 440 with AGP8X
    I/O Port 0x00000000-0x00000CF7 PCI bus
    I/O Port 0x00000000-0x00000CF7 PCI bus
    I/O Port 0x00000000-0x00000CF7 Direct memory access controller

    I/O Port 0x000003C0-0x000003DF Intel(R) 82865G\PE\P Processor to AGP Controller - 2571
    I/O Port 0x000003C0-0x000003DF NVIDIA GeForce4 MX 440 with AGP8X

    Memory Address 0xFD000000-0xFEAFFFFF Intel(R) 82865G\PE\P Processor to AGP Controller - 2571
    Memory Address 0xFD000000-0xFEAFFFFF NVIDIA GeForce4 MX 440 with AGP8X

    IRQ 16 NVIDIA GeForce4 MX 440 with AGP8X
    IRQ 16 Intel(R) 82801EB USB Universal Host Controller - 24D2
    IRQ 16 Intel(R) 82801EB USB Universal Host Controller - 24DE
    IRQ 16 Creative SB Live! Series (WDM)

    IRQ 18 Intel(R) 82801EB USB Universal Host Controller - 24D7
    IRQ 18 Intel(R) PRO/1000 MT Network Connection
    IRQ 18 Intel(R) 82801EB Ultra ATA Storage Controllers

    Memory Address 0xA0000-0xBFFFF PCI bus
    Memory Address 0xA0000-0xBFFFF Intel(R) 82865G\PE\P Processor to AGP Controller - 2571
    Memory Address 0xA0000-0xBFFFF NVIDIA GeForce4 MX 440 with AGP8X

    I/O Port 0x000003B0-0x000003BB Intel(R) 82865G\PE\P Processor to AGP Controller - 2571
    I/O Port 0x000003B0-0x000003BB NVIDIA GeForce4 MX 440 with AGP8X

    I see that the numbers 16 and 18 appear more than once on both lists, but I don't know how to interpret that or what to do about it.

    The multiple instances of Intel(R) 82801EB USB Universal Host Controller - 24D are a result of my inability to discern whether initial and subsequent attempts to install had been successful.

  7. jahtao

    jahtao Guest

    Woah thats some buillsh****t i feel sorry for you..... hmmm.... personally i'd reformat the whoe system before ending it all....... but probably before i did that i'd try my hardware on a friend's machine..... and with different software on the existing one, if you know anyone who'd lend you an interface it'd be good to borrow it and try it on your system..... sound blaster LIVE aint exactly pro gear so i wouldn't expect pro performance but that sounds ridiculous, even still i don't trust that SB and if you haven't got a fully updated cubase well you know.... how about RAM have you got different manufacturers chips in there? Could try removing one
  8. sibleypeck

    sibleypeck Guest

    Are you serious?

    I've tried it with the SoundBlaster removed. Nothing changed. The SoundBlaster is not the problem.

    I'd try it on a friend's machine if, (sob) if I had any friends. Boo hoo hoo hoo hoo!

  9. AudioGaff

    AudioGaff Well-Known Member

    Feb 23, 2001
    Silicon Valley
    As long as you want a general purpose PC, you are preventing yourself from obtaining best possible performance.

    Here is some tips I got from E-MU that really helped my system.
    We would suggest that if have not already done so, optimize your system and XP. Make sure that you are not running anything that is not directly audio related such as virus, spyware, internet browser, email, chat, messenger, spreadsheet, word processing ect.. as well as closing any non audio applications that load on startup and reside on your windows task bar

    Go here for tips on optimizing your PC for audio applications:
  10. cfaalm

    cfaalm Active Member

    Feb 21, 2005
    Home Page:

    Are you familiar with hotfix KB885222? If you are not, read on. If yes then I cannot offer any help.

    Look it up on With SP2 the performance of S400 and S800 was brought down to S100. So your system is actually bandwith starved.

    They offer a download that you can run and then they'll guide you through a registry edit. Follow these instructions carefully. Do yourself a favour and make a back-up of your registry before changing anything.

    I know this because I work on mLAN. After this my system finally worked.

    Good luck!!
  11. sibleypeck

    sibleypeck Guest

    How very clever of Microsoft to provide an update that corrupts an entire means of data transmission, then provide a hotfix that requires one to read fourteen pages of Rube Goldberg's diary before performing brain surgery. That's it. I'll never buy anything with a Windows OS again, unless I need something to $*^t in.

    I'm gettin' a G5. Problem solved. :cool:

  12. pr0gr4m

    pr0gr4m Well-Known Member

    Feb 9, 2005
    South Florida
    Home Page:
    Since it sounds like you've covered everything else, I'd almost guarantee you that this is your problem. It is highly recommended that you save your audio to a completely different drive.

    You have to figure that your computer is running your OS, any background applications, Cubase, any plugins all off of the C drive. Adding audio data to that mix is just asking for problems.

    Create a new project but save your audio to one of the external drives.
    Try copying the audio to one of your external drives. You'll probably need to change the the project in Cubase so that it knows to look for the audio files on the new drive.
  13. cfaalm

    cfaalm Active Member

    Feb 21, 2005
    Home Page:
    Well sibleypeck, I´d look into a Mactel if you want to get rid of MS. These new Mactel babies seem to be really something. All I am saying is that 30 minutes of your time might save you from spending $ 2000,00 right now.

    Even a noob like me can do this fix and it works like a charm. It will take you about 15-30 minutes total and you should have a working system again. Just make sure you download the version with the right language. If that´s English then there´s nothing to it. I needed the Dutch version, which was kind of hidden. The only scary thing was the regedit, especially since one of my cats paid me a visit just after I openend the regedit.

    I agree it´s a sloppy thing on MS's side and we critical users do not easily accept from a company that makes billions of dollars on OSs with errors like these. I guess they were so obsessed with safety issues that they forgot about us DAWers. Hope they will make this up with Vista.

    Wellcome back again to the living :wink:
  14. Thomas W. Bethel

    Thomas W. Bethel Distinguished Member

    Dec 12, 2001
    Oberlin, OH
    Home Page:
    Modern computers are wonderfull pieces of technology until you have a problem. Then, as you have discovered, all he!! brakes loose. I have to say that I never knew about the problem with firewire but it makes sense and I am performing the update as I write this. (nice of MS to let everyone know that the problem existed and that there was a fix for it)

    I am still saying that if this does not cure your problems you need to carefully trouble shoot the machine. I think if you do as other suggested and update the firewire and put your audio files on a seperate hard drive your problems will be solved.

    If not get back here for some other solutions.
  15. sibleypeck

    sibleypeck Guest


    I've manually edited the registry before. I have no problem with that. What I'm afraid of is getting two-thirds of the way thru, then finding out the instructions are vague - and being unable to back out of it.

    Nevertheless, three guys who have done it are telling me to jump. So I guess I will. If you hear a loud noise, you'll know I screwed up.

  16. cfaalm

    cfaalm Active Member

    Feb 21, 2005
    Home Page:
    There is always the possibility to make a safety backup of your C: before doing anything like this.

    I do hope this will fix your problems, because you seem to have tried everything else. Otherwise I agree with Thomas W. that you go through it step by step. Keep us posted.
  17. twon

    twon Guest

    Good start... =P

    sorry, couldnt resist. there isnt anything else running on the firewire bus is there?

  18. sibleypeck

    sibleypeck Guest


    Please explain. What am I to do with this download after I install it?
    Just Run it? Do I have to follow instructions that tell me how to manually edit the Registry? Do I have to do anything besides run the update I download?

  19. sibleypeck

    sibleypeck Guest

    Cruel World,

    I downloaded and installed KB885222. Then I searched the Registry for "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\1394_hc_hw_id\1394_instance_id|DeviceParameters". It wasn't there.
    I found
    "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\", but there was no "1394" after it.
    So I thought, well, maybe the "_id" means the particular controller identification. There was an "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\FW1884\", followed by, "*FDG007\6&3b7028b6&0&00000000", containing three folders, one of which was Device Parameters, so I tried the edit with that.
    There was no "SidSpeed" so, as per the instructions, I added it and modified it. I modified it to "2", which didn't help, so I modified it to "3", which didn't help help either.
    I had backed up my c:drive just to be safe, which took about 2 hours. And the edit itself took about an hour, considering I did it twice, checking Cubase each time. Thank God I didn't waste the whole afternoon.
    So, what now?
    Did somebody say, "Mactel"?

  20. sibleypeck

    sibleypeck Guest

    Okay. I've got it figured out. The Enum\PCI\1394_hc_hw_id\1394_instance_id\Device Parameters is actually Enum\PCI\VEN_104C&DEV_8020&SUBSYS_00D81028&REV_00\4&19FD8D60&0&60F0\Device Parameters for my Texas Instruments OHCI Compliant IEEE 1394 Host Controller.

    Interestingly, in the right frame of VEN_104C&DEV_8020&SUBSYS_00D81028&REV_00\4&19FD8D60&0&60F0\Device Parameters, three things are listed:

    1. (Default) REG_SZ (value not set);
    2. SidSpeed REG_DWORD 0x00000002 (2);
    3. SidSpeedOld REG_DWORD ffffffff (4294967295).

    It appears the SidSpeed has already been modified to S400. Wouldn't you agree?

Similar Threads
  1. krisleuk
  2. purplefish
  3. jenifer
  4. bagerist
  5. Brett Saginar

Share This Page