Will this help my playback issue? (more inside)

Discussion in 'Recording' started by Peredy, Nov 21, 2011.

Tags:
  1. Peredy

    Peredy Active Member

    Joined:
    Nov 21, 2011
    Location:
    NC
    Using Magix Music Maker:

    Midi playback skips and studders terribly, and says 100% of my cpu is used when I use multiple tracks with the synth. I know I have enough Ram and my processor is good. What I'm wondering is if the payback midi thats on my computer is causing this problem, and if getting a new soundcard with a better driver will fix this.

    What sound card type at minimum would solve this issue? And would getting a soundcard that has it's own RAM help? Thank you for any information :)

    Here are my specs:

    Microsoft XP Professional

    4 GB Ram (3.25 showing in properties of my computer)

    2.8Ghz Pentium 4 processor

    Computer: Dell gx270 Optiplex

    Sound Playback: SoundMAX Digital Audio

    Sound Recording: SoundMAX Digital Audio

    Midi music playback: Microsoft GS Wavetable SW Synth

    Thank you for any information :)
     
  2. RemyRAD

    RemyRAD Member

    Joined:
    Sep 26, 2005
    First things first, your Sound Max Digital audio thingy came built inside your computer. It's a $15 soundcard. You can't always expect that a toy device is capable of dealing with sophisticated Professional audio programs. This is why you should buy at least a decent inexpensive professional audio interface of a USB or FireWire type.

    While I feel that the Pentium 4 processor is a minimum, you are also using one of the first whose Non-multitasking capabilities and no hyperthreading abilities may also be a factor in this. That's basically because you are instructing your computer to do multitasking, with too many processes going on simultaneously. While PCs are good at multitasking, single CPUs can quickly become overwhelmed, especially if any other programs are running in the background. Of which there are probably many not needed during professional audio production.

    Frequently, I've discovered that when your CPU indicates it is running at 100%, that frequently indicates some kind of virus activity/spyware/malware/scheduled activities may be lurking within your operating system. Of course the faster processors with hyperthreading or, multiple cores may not be as overwhelmed in operation as a single processor. Or, you may be expecting too much on a single mix without having to render out some things and utilized that way. In that way, the computer does not have to be overwhelmed with too much simultaneous processing.

    Plus, I am slightly familiar with some of those Dell computers, as I received a few freebies. While I have found them very stable, very quiet, for an office environment, I have found them rather clunky, somewhat slow & not very good at multitasking at all. Much of this may also have to do with the type of motherboard employed within the machine. The included chipsets on the motherboard are something reminiscent of traffic cops. And as many people know, traffic cops have a tendency to screw up the traffic worse than any working traffic light does. So your little chipset buddies might be the actual ones at fault.

    I'm utilizing here a Dell Pentium4, 3.2 GHz hyper threaded L170 Which really doesn't multitask worth a damn in comparison to my ASUS Motherboard based custom machine I've built up from scratch. Same processor. Same amount of memory. It runs rings around the Dell. So the Dell is not my primary workstation but more of my general-purpose entertainment & Internet machine if you will. This machine thinks like someone who has had too much alcohol to drink and too little sleep on top of that. So I don't consider this machine a viable workstation for any kind of multitrack audio much less efficient multitrack video purposes. Let's face it, Dell is more closely associated with office-based systems which they do extremely well at. Whereas a purpose built custom PC can be precisely configured for the work it's intended to do.

    In addition to that it also means proper configurations of the operating system have to be modified for work other than on the Internet. You don't want any active virus software nor any other processes trying to update software, automatically defragment your disk drive, automatically scanned for viruses at preset times, screensavers, energy-saving power down/power off monitoring, all that stuff has to be disabled. Paging files have to also be set manually. Number of buffers & buffer times have to be played with. Fancy looking desktops with font smoothing, drop shadows, fade in and fade out, flying in fly out effects and other gobbledygook must be reset to " ultimate performance " within the control panels display settings. After doing all that, even if you don't replace your computer's internal soundcard, things may start working better. And do you really think that the built-in whack whack synthesizers settings are as comprehensive as a dedicated sample playback program?

    MIDI can also be tough if you don't understand what kind of timing reference it must be locked to. These are deep and confusing items for any entry level person to have to try and deal with. That's why some of my clients do nothing more than hire me to properly configure their home studios, along with their computers and then teach them how to work everything. This is like trying to tell a kindergartner about brain surgery and then handing them a drill and a scalpel and then telling them to get to it. Highly unlikely they'll accomplish what they want to upon their first few friends that they experiment upon. And generally, that's a bad idea and why you should try this first with your dog or cat. It's a little more difficult on those mice and rats since it's such a smaller area to work within, like an older, slower, more limited processor. It's sort of like trying to stuff a medium-sized dog into a smaller cage designed for a cat. While it can be done, the doggie will not operate properly in such a restricted environment. And it's also much more likely that if it does function at all, it'll end up with all sorts of poop on its paws. Which is what you currently have. This is not unlike when my 20-year-old geriatric cat used to enjoy sitting upon my closed laptop after use. It liked the warmth. One day I came home and found that Kitty had left me a beautiful deposit & 3 a inch long skidmark across the top of my premium HP laptop. Since I consider this a rather unique and artistic display by my sick kitty, I had to take a picture of it as this effect would probably never be ever reproducible again. I thought perhaps HP may also be interested in it for advertising purposes but they declined. It didn't matter that I considered my kitty to be particularly talented and believed this to be good $*^t (Which you wouldn't necessarily want to smoke). In spite of that, I still deemed it a beautiful presentation by a particularly talented cat, who was as competent as any entry level production person could be expected to be, like everyone here. Never mind that Kitty didn't know how to sidechain what she did with her litter box. No matter, I had to reinforce her and praise her just the same.

    Maybe I should try an orange tabby next time instead of a calico?
    Mx. Remy Ann David
     
  3. Peredy

    Peredy Active Member

    Joined:
    Nov 21, 2011
    Location:
    NC
    Thank you for your response. Out of curiosity I ran the virus scan and looked into everything that looked out of place, and disabled everything that was extra (summarizing all of the things you listed). I am virus free (even in the hidden areas). This is due a lot to the machine being brand new to me and Windows re-installed and all new hard drives. BUT... I suspect your right about what the machine can even do in it's core. SO... this is what I did. I got a cheap sound blaster card, and the MBox mini 2. Problem solved. The soundblaster card is targeted for my regular listening (cd's, internet, mp3's, etc.) and all three recording programs settings are targeted to the drivers and usages (summarizing again) for the Mbox. This worked. There is still skipping here and there but it's so minimal that it doesn't effect anything. All exports without issues.

    Thanks a ton for your insight and I hope anyone else with this issue (as I see from the google search there are many) can see this and hopefully it can help out.
     
  4. RemyRAD

    RemyRAD Member

    Joined:
    Sep 26, 2005
    The only place where the Sound Blaster card has an advantage over the Avid/Digi design product is its ability to play back all sorts of low bit rate, low sample rate, highly data compressed file formats. Perfect for the Internet. Whereas the Mbox has a minimum of compatible file format, sample rate & bit depth capabilities. And since the digital to analog converter in most Sound Blaster cards is on a par with the ones you find in commercial consumer CD/DVD players. So it's more than acceptable. Albeit, it may suffer from some slightly more issues of computer clocking noise that most external interfaces have less of. No matter, it's 100% adequate. So you should be rockin' & rollin', in no time.

    Now since you have both, I'm going to bother you with yet another complication in your recording life. While the M. box was bundled with ProTools 7 or 8, it probably wasn't bundled with ProTools 9. Certainly not 10. However because the M. box is an ASIO box, other software packages can be used with it. Whereas your Sound Blaster card cannot be used with anything other than ProTools 9 or newer. But it can be used with your other audio software. While I don't normally recommend these inexpensive soundcard, it does present for you, with different software such as Adobe Audition, Sony Vegas, etc., the ability to use your Sound Blaster, line level input for tracking with 2 additional inputs (not of an extremely critical nature) but nonetheless marginally adequate. Use that in combination with your M. box and you'll be tracking up to 4 tracks in something other than ProTools. I did something similar to that for for this old guy I met at the church I used to work for on Sundays. He didn't have any money and wanted to make some quasi-multitrack recordings at home. He had a reasonable desktop machine with 4 open PCI slots. So at a bulk computer sale, I picked him up 4, $12 PCI soundcard's with line level inputs. Then I was able to plug his Mackie or was it a Beringer thingy into this and voilà, 8 simultaneous tracks of record through Cool Edit Pro 1.0. He was happier than a pig in $*^t. Of course monitoring could become a little dicey since you couldn't monitor all eight tracks while they were recording from the output of a single card. That required a slight kludge of a passive, cheap and dirty, Mono monitor mixer with $10 of Radio Shaft parts. Total cost for a 8 input recording system for the computer was around $60 which sure as heck beats $500. Did it sound as good as the $500 units? Certainly, not totally, especially for those persons technical skills, budget, desires. It's actually rather surprising to hear how well a Beringer can sound plugged into the line input of a Sound Blaster while not overloading anything.

    Who knew? I did.
    Mx. Remy Ann David
     

Share This Page