Skip to main content

First time I have tried to turn on phantom power on this recorder - going to the menu and input, I get the option for +48V or +24V. Selecting 48 causes the thing to shut down. Any idea what is going on?

Theis is without anything plugged in at all.


pcrecord Tue, 07/25/2017 - 12:52

Kurt Foster, post: 451518, member: 7836 wrote: 2 AA batteries trying to do 48 volts may be the problem.

Good call Kurt!
Or it's the type of battery.. What are you using ?
I know that my sennheiser wireless packs won't start on cheap ones.. Duracell or energiser works.
I can strech it to rechargeables but they must be NIMH higher than 1000mah

paulears Tue, 07/25/2017 - 13:56

I've found the cause - but not really sure why it does this - it was in 4ch mode - 2 XLR plus the 2 built in mics. Turning it tp stereo mode, then selecting inputs 1 & 2 allowed 48V to be turned on without shutting it down - and the two AA alkaline cells power the mic fine. How strange? Worth knowing if you have one - 4ch and phantom is not a possible combination - but to be honest, it should be?

arfo Sat, 12/03/2022 - 10:35

I just tried now and it worked; two stereo included mics and my Rode NT3 on channel, zoom connected to the electricity grid. Matrix m/s on.

Hope it helps,


paulears Tue, 12/13/2022 - 11:57

Not really - trying to work out when is best to replace the £3 battery in a CL series Yamaha mixer that has gone flat, so we daren't turn it off. In between two shows a day, or before the first one? It loses everything, including stuff not in the saved file!


User login