Skip to main content

Golden Age Project Pre-73 MKII, did I just get a lemon?

Hello!
This is my first posting here though I've been reading many of the opinions on all the things that I'm completely obsessed with; that is studio gear, cool Microphones, beautiful instruments...
But my first question is pretty straightforward. I've got an ever-growing pile of really nice mic-preamps, from 3 CAPI (2 VP28 and 1 VP312), a Neve 511, a Focusrite ISA one, a UAD 4-710d, and assorted others that fill the "not bad" heading. And then I have the Golden Age Project Pre-73 MKII. And the problem I'm having is that with all my other mic-pre's it's really a pretty easy process to dial in a great sound with a very good mic (AKG 414,Sony C-37A, Advanced Audio CE12, WA 67, among others) but with the pre-73 I feel like I'm struggling to just have it not only not distort but have the damn thing sound good at all!!!

So my question is did I just get a lemon? Though I've had good experience with Golden Age in the past maybe this mic-pre is just not that good? Maybe, god forbid, I'm not using it correctly? Maybe there is a good mod that can make this mic pre sound better? I mean I know it's not going to sound like a vintage 1073 but come on!!!
Any and all advice will be greatly appreciated.
Thanks Harry

Comments

kmetal Fri, 02/04/2022 - 14:25

Welcome to RO! presuming your gain staging is correct is does sound like a hardware issue. Hopefully @Boswell catches this thread and can recommend some tests to do, I'm not particularly skilled in that area.

I would test it at medium to low input and output gains to see if the distortion goes away, reduces, or stays the same.

Harryohm Fri, 02/04/2022 - 14:58

In reply to by kmetal

Great suggestions thanks. I think I've been spoiled with so many great mic-pre's that sound great and then this one distorting all over th place. And I think you're right that I should run it through all the basic tests (different source both mic and line, different chords, maybe even tests it through a different interface...
I have tested it all before but I think I'll start from scratch.
Thanks for the advice!
Harry

Boswell Fri, 02/04/2022 - 15:06

Can you post a clip of what you are hearing as distortion with the GA pre? Not more than 10 sec should be fine.

pcrecord Mon, 02/28/2022 - 08:04

I did buy 2 UK sound 1176 mic pre (clones of 1073 with compressor) and had to sell them not long after. It was noisy and not sounding as rich as other mics I own. 

It certainly gave me apprehension to ever buy other clone preamps. I have a Warm audio U47 clone which is ok, then 2 Golden age LA-3A clones who sound very good. I'm sure some clone preamps are good, but I just got a bad taste. 

I replaced them with a Manley force and I'm very happy with it. 

I also own ISA preamps and the UA-470 (which I feel being very easy to distort)

All in all, there could be problems on mass produced units like the Pre-73.. 

Let us know if you had it replaced or found the solution.. 

Harryohm Tue, 03/01/2022 - 04:24

Thanks for the input. I also have an ISA one and it's a great pre-amp. I also have some API and Neve pre-amps and a UA 4-710d which is amazing. So I didn't really need the pre-73 and I also didn't really like the sound.

So I sold it and now I don't worry. I also have a Warm Audio Tube mic which sounds great! So I'm not down on all clones as some are very good...

 

x

Register