Skip to main content

I have a GS 3000 console turn of the century stuff. The Mute mpu board has gone out part 002-347-1 so all the mutes seem stuck off and mute and status leds are stuck on. No LCD. Everything else works.
Need to find a replacement or figure out how to fix it. The pcb makes use of a P80C32 40 pin chip and what appears to be a 5v power supply.
Any ideas?


Boswell Fri, 03/17/2017 - 11:12

I've never had to dive inside that particular model of mixer, but I have done servicing on many other A+H consoles, and know that there is a fair degree of commonality between ones of a similar vintage.

I don't know what type of test equipment you have access to, but the main things to check on that board would be the 5V power being present (multimeter), the crystal attached to processor pins 18 and 19 actually oscillating (oscilloscope), the reset line on pin 9 not being held low (oscilloscope), as well as checking to see if there is any activity on the external EPROM address and data lines (oscilloscope). After that, it's a matter of removing the board from the mixer and carrying out a detailed visual check. This should include applying a light sideways prod to every pin of every component with the sharp end of a scalpel blade to check that the solder joints are still good. Ideally, this needs to be done under an assembly microscope, or at least a reasonably powerful static magnifier, so that even small displacements of the pins under slight pressure can be seen, and also the quality of solder joints inspected.

Another of the things that can happen with age in this type of gear is that the EPROM device that holds the program instructions can start to fade, causing corrupt data. Erasing and re-writing the part normally gives it a few more years of life, but the problem is that unless you have an alternative source of program data, you can't guarantee that what you read out of the fading one is correct, and you end up reinforcing the flakey data.

Perhaps you could indicate the sort of actions you feel you would be able to carry out on the board, and I could advise further. It would also be useful if you could post a close-up photo of the board.

Good luck!

Kevin Porter Fri, 03/17/2017 - 22:48

Thanks for your thoughts. Much appreciated. I have more test gear than brains. I have a TEK 465 with multimeter built in. It a bit wonky but works. I know very little on how to use it effectively.
Best i can tell is the 16v +- and 48vpp from the external PS power supply appear inside the console and powers everything up. The MPU feeds off one side of the 16v supply into a 5volt regulator circuit on the MPU. This 5v seems to drive the whole MPU system. The main brain i guess is the P80C32 which is the chip you are talking about.
OK so i will test for a ripple free 5v and try those oscilliscope tests you mentioned. I have no idea what im looking for but i assume i ground my probe to the chassis and clip the positive on pin 9, 12,13, 18,19, 40 and report back what i find.
I have a couple of bin files i got from the A&H site v1.11 and v1.12 which appear to be the program info???
I will get a few pics up tomorrow.

Boswell Thu, 03/23/2017 - 12:33

I've located the schematics for the GS3000: here. The MPU board I think you are referring to is shown on pp16-17 of the document, with a positional drawing on p18.

A couple of quick questions for you:
(1) could you confirm that the 27C128 EPROM chip IC17 is fitted in a socket?
(2) what voltage is there on the BREAK test point P1? I don't need the exact value; it will be either near 0V or near 5V. Test point P1 is located between pin 1 of the MPU and the transistor Q3.

As you mentioned, A+H give a pair of .bin files for this mixer on their site. The contents of the files include strings showing they are version 11 and version 12 automation files. Since the MIDI controller is also on this MPU board, it's likely one of these would be correct for re-programming the board's EPROM, if it comes to that.

If the EPROM chip is fitted in a socket, it may be worth re-seating it when you have the MPU board removed from the mixer. Use a twisting motion of a small flat-bladed screwdriver to pry the two ends of the chip alternately upwards, lifting it a millimetre or so, but don't allow any pins to jump out of their socket contacts. Take care to ensure you insert the blade of the screwdriver between the chip and the socket and not between the socket and the circuit board, as is easily done. After the slight lift of the EPROM, use your thumb to press the chip back into the socket, applying firm downward pressure alternately to the two ends.

Kevin Porter Thu, 03/23/2017 - 15:05

Yes the 27c128 Eprom is on a socket.
I have P1 Break as being pin 12 or(p3.2 int0) on the P80C32, not pin 1 and going to Q15 instead of Q3. I am guessing Q3 and Q15 are part of a PS monitoring circuit that send a signal to the chip to turn off if there is a PS issue. Is this correct??
I will try and get a voltage measurement at P1 BREAK later as my VOM is not here right now.

Kevin Porter Thu, 03/23/2017 - 15:34

OK Very interesting stuff,, Bozwell gets a medal.
So in manipulating the IC in the socket as you suggested the mixer now boots like normal and all Status lights are off and the mutes work. So i consider it a fix thus far.
I also checked the voltage at pin 12. So when i would power the power up it would go to 4.78 volts for about 2 seconds and then fall to .22 volts. Lights on the front flickered as well for about 2 seconds prior to going into freeze mode.
After messing with the eprom i get a steady 4.8 volts off pin 12. I think i learned something.
Bozwell,, would you mind PMing me your address please. I would love to send you a little blessing!!

Kevin Porter Tue, 09/04/2018 - 10:44

Its been a while. The repair lasted over a year but the other day the same problem happened again. Its amazing what you can forget in a year and i have had to re familiarize myself with this issue. I am going to try the same trick that worked last time but i need a more permanent fix. I can live without the mute system so wondering if there is a way to bypass the whole midi mute system?

Kevin Porter Tue, 09/04/2018 - 17:33

I find it amazing that the mixer operation depends on the 5v logic being operational and that a circuit board the size of a pack of smokes can render the entire mixer a paperweight. I contacted Allen & Heath again in the hopes of getting a replacement mpu from somewhere or a componet level repair on the mpu i have.

Boswell Tue, 09/04/2018 - 23:51

If the fault has the same symptoms as previously, it's worth going through the EPROM re-seating process again. Mild corrosion on the chip legs will probably get worse over time, and, short of fitting a new socket and copying the EPROM content to a new chip, there's not a lot you can do apart from regular re-seating. Applying a small amount of contact cleaner to the chip legs at the start of the re-seating operation could stretch the time between failures.

Without attempting to find the precise detail of the start-up operation of the MPU, I'm not able to tell whether removing the MIDI board and hard-wiring the pins on the connector is a possible work-around. My guess would be that it would not leave a workable mixer.

Kevin Porter Wed, 09/05/2018 - 13:29

Thanks for the quick response. Well seems the best thing to do would be to have the mpu board serviced and programmed to restore proper function. Who does that kind of work and can it be done without the mixer on hand?
I have no idea who to approach on that issue. In the meantime i will try the re seating method and hope for the best given it has worked in the past.. Mixer is still not torn down yet. Might get to de wiring it tonight which is the biggest part of the job.

Boswell Thu, 09/06/2018 - 02:13

If simply re-seating the EPROM restores normal operation (at least for a while), then having the MIDI board serviced would be a relatively straightforward thing to do. You would have to schedule this for a slot in your usage, as you would not be able to operate the mixer while the board was away.

My suggestion to any local service engineer would be to replace the EPROM socket with a turned-pin type, and also copy the EPROM to a new device of the same type, if one can be found that has been stored vacuum-sealed so that it does not have bad oxidation on its pins. I would offer to do the job for you, but it may not be worth sending the board on a return trip across the Atlantic.

Kevin Porter Thu, 09/06/2018 - 16:47

Thanks Bozwell, you never know i may take you up on it at some point. As it turns out one of the A&H distributors has an MPU so im probably going to buy it asap so at least i have a working one. Seems its prudent to have a couple around. My mixer had this issue brand new out of the box and they replaced the MPU on site. That one has lasted well but the same issue has happened since three times now, so its a weak point in the design. I put a few requests out locally for someone to fix the old one, if i cant find someone i will send it to you. I must add you have been extremely helpful thus far. Thank You!!

Nanner Puddin Tue, 10/16/2018 - 12:26

So I, too have a GS3000. I have had exactly the same problem. I got it to work again for a while by reseating the eprom, as was mentioned by Boswell. It finally went completely kaput a month ago and is at a local tech repair place. I am trying to track down the eprom or the MPU board. I am in the States and our distributor does not have any left. Steve, did you get yours from the Ericson Pro in Quebec?



Kevin Porter Tue, 10/16/2018 - 14:54

Seems a common problem. Three times for me!! I have not ordered a replacement part as of yet. It takes 4 weeks at least for A&H to make them and get them to the distributor. I am going the other route and i am going to try and program a new eprom and install a new socket on the existing MPU. In the meantime i have re wired my studio and bypassed the mixer completely and i am using rack mount preamps etc to get signals into my DAW. Actually works well other than a lot of mic line patching between rooms and the rack mounts. I have been looking for a replacement eprom socket with gold plated contacts. They dont seem to exist on ebay or the like anymore, likely due to gold prices. I found a used socket in an old Sparx computer i may butcher to get the part if i cant find one elsewhere. Erikson is my distributor for A&H in Canada. I did contact them about a replacement MPU but didn't want to put money down and wait 4-5 weeks although it may end up being what i do anyway because there is no guarantee my repair will even work out.

Boswell Tue, 10/16/2018 - 15:48

Nanner & Kevin - I'll contact A+H here in the UK to see if they have replacement MPU boards for the GS3000, or any other recommendations to fix what must be a common problem.

You don't need gold-plated sockets - just the standard turned-pin ones grip the chip legs much better than side-pressure sockets.

Boswell Wed, 10/17/2018 - 07:15

I talked to a helpful engineer in the service department at A+H (UK), and he said EPROM pin-socket corrosion was not a common problem on the GS3000, or on any of their products, for that matter. He said that the N. American distributor (AM&S) has a large stock of spares, which should include the GS3000 MPU board. However, they could only sell through one of the several US or Canadian A+H dealers. The UK factory has no MPU boards in stock, it being "such an old product".

I would give one of the US dealers another call, asking if they can check the MPU board stock position at AM&S. My offer of fitting a new EPROM and socket to your board(s) is still open if you cover the trans-Atlantic postage costs.

Nanner Puddin Wed, 11/07/2018 - 12:51

Update: Well I got my GS3000 back from my local Genius type tech guy. It turned out that there was a cold solder joint on the MPU that was causing the problem. He fixed that up and now it works fine. There was also a cold solder joint in one of the group meters, so this very well could be an issue endemic to the time period and/or factory where A&H produced it. Anyway, I do plan to get an extra MPU from A&H if I can, as a real failure on that could really screw me over in the future, as I plan on keeping this for a long time. Thanks to everyone for the help and good luck Kevin!!!!!


Kevin Porter Mon, 11/12/2018 - 17:09

I just ordered the part from Jam Industries located here in Canada. They are the national distributor for A&H. Its a 3-4 week wait for them to get the part. It about 120 bucks all told.
I have since bent and broke pins off the last eprom trying to get er going again. Not this time. LOL
If i had more money i would have ordered a few of them. Jam part number is
002-347JIT GS3000 MPU PCB
Web page

Nanner Puddin Mon, 06/03/2019 - 14:46

Well crap, mine just died again. One thing is wierd, every mute is on except the two Mutes for the AUX busses just above the master section. I have some jobs coming into the studio so I have to get this fixed quickly. I called Full compass here in the states and the said they can get a replacement but it will take 4-8 weeks on backorder. I went ahead and ordered even though I expect to be disappointed the same way as Kevin was. I also ordered an EPROM programmer and some blank EPROMS and sockets from EBAY. Hopefully I can get this fixed up as I really love this console!


Boswell Mon, 06/03/2019 - 15:30

Most likely to be bad contact between the EEPROM pins and the socket. If you have the official download of the EEPROM contents, it's worth programming one of your new ones and simply swapping it over to see if that makes any difference. If it works after doing that, use it for your immediate studio jobs and then consider swapping out the socket when you are under less time pressure.

Kevin Porter Mon, 06/03/2019 - 16:28

I managed to fix mine. I burned a eeprom and that didn`t work but hey i learned to burn eeproms!! Turned out the 5 volt regulator was blanking out in the power supply so i would check that out. Simple one dollar fix. Solder in a new regulator. Its been good ever since. I had broken legs off the original eeprom popping it in and out several times so the one i burned came in handy after all. There is no choice but to fix the MPU you have seeing as there is no supply for MPU`s anymore.

Kevin Porter Mon, 06/03/2019 - 16:53

The hardest part about the repair was decabling the console and staring at it forever once i had it standing up with the back off it. LOL I too love this console. Its been great and im quite happy i didn`t have to send it out anywhere to get it fixed. I actually bought all the parts in the power supply and was going to replace them all but once i changed out the regulator and it started working i just put it back together and will save the other caps and resistors for another day..Dont lose hope. Its a great console and can be brought back. If i could do it so can you. Bozwell has been a great inspiration in this endeavor and i have learned a lot as a result of his guidance on this and other repairs i have made to other gear i have.

Nanner Puddin Fri, 06/07/2019 - 14:18

Well how about that! I stood the console up and started checking the voltages on the MPU starting with the 15.6v input. I went backwards then from the 5V side and there was no voltage until after the 1 Diode. I poked around some more with the DMM and the all of the sudden it came on. In effect, the old circuit disturbance test. I pulled the board and reflowed the solder joints on the regulator and the diode. She is back in place and running as of now. I am now on a mission to aquire all of the spare parts I can that are on that board, and still available.

On the plus side, I now have an EPROM programmer, a bunch of sockets and some blank EPROMS. I also have not heard back from Full Compass on whether they can get a spare board from A&H. I expect that to be a bust, but I will keep you guys posted.

Thanks for all the help Kevin and Boswell!


Kevin Porter Fri, 06/07/2019 - 17:53

Awesome! I had a feeling you would ace it one way or the other. The parts on that MPU are pretty common and you should be able to get them just about anywhere that sells electronic stuff. All in all its a pretty bullet proof console aside from the MPU. I have never had any other issues with mine other than the only "digital" pcb in the console. I expect its a happy day in Knoxville

ByronDonald Mon, 02/17/2020 - 09:20

Hi..i am looking through the schematic it appears there are 3 supplies that branch off from the main outboard PS. VA VB VC. They all appear to be fed from the 16v+ and 16v- plus ground from the external power supply I think my problem may lay in the VA part of the supply. Looks like the filtering and IC regulation is inside the mixer so the next step is to de wire the mixer and get it into an upside down position to work on.
Probably a 50 cent cap causing all this grief.

Andy Halliday Sun, 08/23/2020 - 23:54

Hello everyone :)

Guess what! I too have a GS3000 with all the MIDI lights on and no signal anywhere!

Actually, it's not my board, it was in the studio I just started working at in Southampton, UK. The studio has been a bit neglected and the board belongs to someone else who used to record here.
I decided to plug it in and see how it compared to direct in recording to the Focusrite Scarlett 18i20... I'm sure it's going to be magic if we can get it working again... I'd love to be using the board and the tube pres...

So - I need to open this beast up and resit the EPROM, right? OK - here goes!

Nanner Puddin Mon, 08/24/2020 - 05:15

Andy Halliday, post: 465303, member: 52035 wrote: Hello everyone :)

Guess what! I too have a GS3000 with all the MIDI lights on and no signal anywhere!

Actually, it's not my board, it was in the studio I just started working at in Southampton, UK. The studio has been a bit neglected and the board belongs to someone else who used to record here.
I decided to plug it in and see how it compared to direct in recording to the Focusrite Scarlett 18i20... I'm sure it's going to be magic if we can get it working again... I'd love to be using the board and the tube pres...

So - I need to open this beast up and resit the EPROM, right? OK - here goes!

Hey Andy, so when you say the MIDI lights are on, do you mean the Mute buttons are all red? Do you see a Green number in the LED diplay in the center section(probably a 1)? If the mutes are on AND there is no number, it could be the EPROM, but it might be that there is no power to the internal MPU board. That was the case with mine and the culprit turned out to be a bad diode in the onboard power supply right before the Voltage regulator. It would be well worth your time to trace the voltage from the supply wire( i think 24v from memory) all the way to the 5v that the eprom uses.

Once I figured out the problem, it was an easy fix. Before that it had bedeviled me for quite some time, as it had worked intermittently. I love my console and I think if you can get it running you will too.

I hope this helps!


Andy Halliday Wed, 08/26/2020 - 03:47

Hey Doug,
Forgive me - yes - that's what I mean.
Mute lights are all on. No green numbers... I look forward to this beaut working properly!
I have no intermittent fault - it does the same thing every time I power it up.
You mention "It would be well worth your time to trace the voltage from the supply wire( i think 24v from memory) all the way to the 5v that the eprom uses."
What would I do to achieve this? I can't see even where to unscrew to get inside the board at present and am not massively experienced with electronics. That said, I have a GCSE in Electronics, made a Monome controller once, to apart an SSL at work once to update it or something like that, and am confident I can achieve the required result if I have a guide or some such...
Any help appreciated in where to start!
I also have a fairly cheap but prob not too bad multimeter and soldering iron!
Peace thank you

Boswell Wed, 08/26/2020 - 04:49

There are several likely causes for this problem:

1) Low or absent power to the MPU board (the fault that Doug described)

2) A poor contact on either the MPU board connections or the EPROM pins

3) A hard fault on one of the MPU board components

4) An EPROM image corruption

Of these, faults 1 and 2 are the more likely. Identifying which one would require access to and maybe removal of the MPU board.

The GS3000 schematics are downloadable here. Since I have never had to get inside a GS3000, I'm not the best one to guide you on that task. GS3000 owners Doug or Kevin here may be able to offer help on that.

Nanner Puddin Wed, 08/26/2020 - 06:15

So first, make sure do download the schematics in the link Boswell included. In fact, you should download every document that is related to the GS3000. Next, you will need to stand the board on its back on a sturdy table(hopefully yours has the meter bridge). Elevate it with a couple of 2x4s so you will be able to test it while powered up, but don't attach the power yet. There are a series of screws around the edge that hold the bottom cover on. Take those out and you will see the MPU board just off center and attached with screws and one red wire and one green wire. The top quarter of this board is the power supply. This will match the schematic on page 16 of the schematics file. Start by checking the voltage on the red and green wires. The red is positive. I should read ~16v. If that is fine then leave the ground probe on the green and check the voltage on the third leg of the voltage regulator(the right leg). That should be 5v. If not, the problem is somewhere between those two points so you will have check each component along the way.

I would very seriously consider having someone around as a helping hand for this, as you will want to place your probe then turn on the console to check the voltage, then immediately turn off. If the probe accidentally touches two points at once it could cause a lot of damage to the circuit, so use that process for each component. I hope the picture helps, that is the MPU from my console. If you have any questions please let me know.

Oh, and if one of the components is bad, you will have to remove the board to replace.

Boswell Wed, 08/26/2020 - 07:01

That's a great set of instructions and an amazingly clear photo from Doug. On his unit at least, the microprocessor is soldered in, but the V1.02 EPROM is in one of those terrible side-force sockets. My guess is that one of the EPROM pins is no longer making good contact with its socket. That type of socket causes a perennial headache, and it's why I had constant battles with the bean-counters in various companies' design departments to use the more expensive turned-pin ones. How do you put a cost on a reputation for reliability?

For your unit, try the EPROM re-seating technique I detailed in post #5 of this thread, taking GREAT care that your screwdriver blade that does the twisting slots in between the EPROM and its socket and not between the socket and the circuit board. It looks as though you should have sufficient access to use a small plastic-handled screwdriver for this task without having to remove the board from the mixer. Be sure the mixer mains lead is unplugged from the mains while doing the re-seating. If you follow Doug's positioning suggestions, you can re-power and check before moving the mixer or putting the bottom cover back on.

Let us know the result of re-seating, so we can advise you on what to do next.

Andy Halliday Thu, 09/03/2020 - 06:28

Hey so we've taken the bottom off and measured the voltage between the earth and red on the board both at the point the power enters the desk itself, and the MPU board - both read 1.6v... so it seems like there is not enough power actually reaching the board.
I tried re-seating the chip and it didn't work either BTW - so we're wondering if perhaps the power supply itself is having some issues?
Or maybe we're doing something wrong? Of course, always question ourselves first lol.
Thanks for the pic and help it's been very nice thank you


User login