Skip to main content

MIXER - VU Meters no longer illuminate.

Hello fellow recording enthusiasts,
While I have read through this forum many times, this is my first time as a registered user. I own an older Yamaha MR 1642 analog mixing console. I simply love the smooth sound of these old preamps this board has. The board has functioned as it should, without issues for the last 29 years, but recently it acquired a rather annoying symptom. All six of the VU meters simultaneously lost the ability to illuminate. This makes it very difficult for my eyes to see the meters. I have yet to open her up to investigate possible culprits. I was curios if anybody has had this happen on this mixer or any other older consoles. Do you think it is something as simple as a fuse, or something more serious? Any help would be greatly appreciated. Thanks all!

Comments

KJW Productions Thu, 10/01/2015 - 23:15

Wow, that was a fast response! Thanks for the help. It is odd that all 6 just stopped lighting up. That would be nice if all it was, was a bad electrical connection. I am hoping that it wasn't some sort of electrical surge that happened to blow all 6 lights at once. All of the meters still function, just no lights, and far as I can tell, the rest of the mixer is fully functional as well. I do plan to open her up to investigate, but before I do, I am waiting to see what suggestions pop up on here. Thanks again.

Boswell Fri, 10/02/2015 - 02:49

The meter lights are supplied via a 1A fuse labelled F905 on the MR-B circuit board. This is the board that connects to the three secondary windings of the mains transformer. There are four fuses on that board, two rated 1A (F905, F902) and two rated 2A (F903, F904).

If you don't have a meter to check the fuse continuity, you could try powering up briefly with F905 and F902 exchanged to see if the meter lights then come on. However, if there is a fault in the meter light circuit, the danger is that you could end up with two blown fuses.

bouldersound Fri, 10/02/2015 - 08:46

If you don't have a meter get one. It's worth it just for testing cables. I've got three or four scattered around, plus a clamp ammeter, a non-contact voltage detector etc.

Good thing there's a fuse on that circuit, but what a burned fuse can mean is that there's something wrong there that's causing excessive current draw. If you replace the fuse and it burns out again it's time to look deeper. I'm no electronics tech but I've learned a little about what to look for. Any signs of overheating, like discolored or blackened PCB, point to possible problems. Cracked or pasty solder joints and capacitors that have puffed out at the top are other things to look for. I don't usually do the repair myself but I pass the info to my tech who can often diagnose it remotely.

MrEase Fri, 10/02/2015 - 10:29

Just a note with blown fuses on lights is that in the process of blowing, an incandescent lamp can cause a current surge enough to blow the fuse. I'd be prepared with a couple of spare fuses and also a spare bulb. This is just the same as domestic lighting where a bulb blowing can cause the circuit breaker to trip.

dvdhawk Fri, 10/02/2015 - 22:20

You couldn't ask for better advice than what you've already been given. It sounds like you've got the gear to test it and get to the next level of repair.

bouldersound, post: 432795, member: 38959 wrote: If you don't have a meter get one. It's worth it just for testing cables. I've got three or four scattered around, plus a clamp ammeter, a non-contact voltage detector etc.

I agree and believe all of our "fellow recording enthusiasts" should have at least one multi-meter, and at least master the basics of how and when to use it to test voltage and continuity.

rmburrow Sat, 11/18/2017 - 08:58

KJW Productions, post: 432787, member: 49477 wrote: Hello fellow recording enthusiasts,
While I have read through this forum many times, this is my first time as a registered user. I own an older Yamaha MR 1642 analog mixing console. I simply love the smooth sound of these old preamps this board has. The board has functioned as it should, without issues for the last 29 years, but recently it acquired a rather annoying symptom. All six of the VU meters simultaneously lost the ability to illuminate. This makes it very difficult for my eyes to see the meters. I have yet to open her up to investigate possible culprits. I was curios if anybody has had this happen on this mixer or any other older consoles. Do you think it is something as simple as a fuse, or something more serious? Any help would be greatly appreciated. Thanks all!

If that board is 29 years old, take a close look at the power supply capacitors while it is open. That board may be due for re-capping, especially if you see any evidence of heating or electrolyte leakage. As for the meter lights, all incandescent lamps draw inrush current when cold started.. this alone could have weakened the lamp fuse over the years until it gave out...

x