Skip to main content

hi, got a new kronos and want to use as my main keyboard to trigger plugins on Ableton live and also to use as a sound generator utilizing the kronos internal sounds to go directly into Ableton via the usb cord.
i have the Ableton recognizing the kronos and able to use it as keyboard to play sounds on Ableton but can't get it to send the kronos sounds to ableton. i have the recent Korg editor software installed as well as newest midi driver.
i cannot get any help on the Ableton forum and am wasting tons of time in the dark not know what to do. any help would be major league appreciated. i would even pay for some phone help. anyone using these two items together.
btw, am using Focusrite saffire dsp 24 as interface for monitoring from the daw.
thanks. mick

Topic Tags


audiokid Thu, 06/27/2013 - 00:37

Spot on Hue!

I have a Kronos X. Love it. LOVE IT! Here it is in action:

As Hue say's, you need to send audio to the DAW. Kronos only sends midi to it. But, I hoped the same thing as you. Their control panel appears to be able to do this but its pretty crappy right now. They may get the software to be able to send the actual audio out by means of some plug-in. There is a plug-in but I don't know what its good for, do you? Wouldn't that be nice if it actually did what it was supposed to do? But, the Kronos is a HUGE computer in itself so I doubt a DAW computer could do it as well as the keyboard can.

Use your DAW to send midi to it and track the audio on a capture track. This is what I do.


micksmuse Thu, 06/27/2013 - 10:03

hi, thanks for responding.
all the documentation and videos state that the usb a/b cord can go into computer directly and transmit midi and audio (2 channels of audio). so is what you are saying that it states that but in real life it just doesn't work?
i have the editor vst plug-in installed and ableton recognizes it and once again it states that if you turn local off on the kronos you should be able to use the kronos as a vst and get the audio in via usb.
so i am guessing you have tried this and it does not work.
if in fact the usb midi/audio connection can't be done i guess not much i can do about it other than a work around. sadly i am not a midi guru and my head is spinning.
couple questions since you are using the kronos.
if i have the keyboard on kronos being recognized with ableton and i can record midi data to a armed midi track on ableton how would i get the audio onto another track using the sound from the kronos?
i assume i would have to arm another audio track and have the midi track going into that track but how would i get the audio from the kronos onto that track? sorry if this is a naive question but am a newbee.

audiokid Thu, 06/27/2013 - 19:19

Hey, I missed that memo on turning off Local! If this actually does it, Thank You! I will test this out and get back to you on that.

Its kind of confusing working externally but you have to set the midi channel to send that data to an external source.

I stereo DI the Kronos audio into my converter then arm an audio track ready for the Kronos.
I have a second midi track set to receive and send out the data from the Kronos via a midi connection on my interface. NOTE: I haven't been using the usb on the kronos because it was a waste of a port but this may change now.

Never the less, if you are able to send the midi data to Ableton USB then all your need to do to complete the process is send that midi data back out to the kronos. It will then trigger the external audio and you simply record it on the audio track. Make sense?

Remember to deactivate the midi record while tracking the audio from the Kronos otherwise the midi data will not be sent out and you will be wondering why its not working.

Let us know if this helped?

audiokid Thu, 06/27/2013 - 22:09

I gather you saw this on the other forum that you were looking for the same help:

In order to use USB audio from the Kronos you have to select it as your soundcard. On Windows, this means using WDM or MME drivers, or installing ASIO4ALL if you want to use it with ASIO drivers. The Kronos does not come bundled with audio drivers. If you want to use your Saffire as soundcard, simply use audio cables to hook up the Kronos to it. Then make an audio track in Ableton, select the correct inputs on your Saffire, and enable input monitoring.

That solves the mystery for me. Korg obviously needs to do some serious homework on vsti DAW integration. No professional recording system uses those 2 track drivers for professional multitrack recording. At least from my experience.

What a joke.

Good luck on your quest...

micksmuse Thu, 06/27/2013 - 22:25

i spoke with the tech guy at korg today and he told me that the editor as a plug in vst on ableton if i am using windows 8 is not cleared by korg so that might be the problem why it is not communicating with the kronos. he said (we are working on it) so i think we can be assured that there will be a fix by the time miami is underwater.
looks like i am left with just doing one midi and audio track at a time with the outs on the kronos into my focusrite interface and into that monitored audio track like suggested above.
also found out that if i was using the kronos as an interface with the archaic 2 track drivers that i couldn't monitor with headphones from kronos. because the returning audio from ableton doesn't get routed to the main stereo outs.

thank everyone who responded to clear a lot of the issues up. good luck on your projects. mick