Skip to main content

Wharfedale Pro Titan Sub-A15 Troubleshooting

I have two Wharfedale Titan Sub-A15's and they no longer work due to an unknown issue. Does anyone know whether these subs are reliable? Any way to troubleshoot?

Comments

cyrusc Sun, 04/24/2022 - 17:36

audiokid wrote:

I know this is an obvious question but can you explain anything more? Did they just suddenly stop? 
 

not sure if this repair video will help 

 

We had these subs sitting under my school stage since before my time and we were curious as to if they were going to work or not. Upon further inspection and testing, they turn on (the green light is active when the switch is clicked) and nothing seemed to be heating up or burning but still no sound, not even a hum. When we tried to play something on it, no sound was produced. We checked the fuze and it is intact and should be working. 

paulears Sun, 04/24/2022 - 23:05

From my time in colleges, I suspect they both got overdriven, and both died of the same thing at different times. The cause is lack of technical supervision, so they make the usual signs of distress, and sort of cry out in pain, then one dies. The volume to the other is of course then turned up, and it dies the same death. It’s common for the driver to fail due to overheating, and there are two outcomes, often sadly, a short.. current demand goes up and the output devices fail. 
 

first step is to check the speakers, and then the output devices. If there is no physical signs of distress, you might even be lucky and the speaker drivers just failed open circuit, not short, and that’s better!

cyrusc Mon, 05/02/2022 - 05:40

Had some time over the weekend to take apart the circuit board, please see below:

  • image_123927839_1.jpg
  • image_123927839.jpg
x

Register