Skip to main content

Hello all, i'm new to this forum so i might be posting on the wrong sub-forum, excuse me if i am.

So here's my problem, i've done everything i found in the internet and nothing seems to fix it. I recently bought a Focusrite 2i2, and i wanted to plug it into Cubase and record songs, after i had some trouble with defining the sound card, i managed to get the setings right. I have the bus and the VST device ready and all. But i can't seem to make Cubase take input from the soundcard, it keeps saying ASIO driver is not working and i don't see any sound-meters moving while i play. I'll attach some pictures so you can see the setup i made, i really hope someone can help me here :(

Topic Tags


anonymous Tue, 04/08/2014 - 06:09

a few questions:

You've gone to the Focusrite page and made sure that you have the latest driver updates for the Focusrite for your system?
Have you made sure to select ASIO as your driver within Cubase itself?? You're not set for WDM or something, right?
Have you disabled all other audio drivers within your PC... like a built in Realtek or Soundblaster card?
Is the Focusrite set as your default audio device for your system?
Do you get sound through your Focusrite if you play a CD or stream online audio/video?

You may want to try asio4all. It's a third party driver that can occasionally work better on certain systems.

pcrecord Tue, 04/08/2014 - 09:40

Following the recommendation of DonnyThompson ;

Once you made sure you have the latests drivers. you should know that any audio interface is prone to have mishaps if the audio buffer is not set properly.
You should start at 256samples and try 512 or more.

Also, close any software that can use the interface in an exclusive way.

scarlett products used to work well in Asio. I used a 8i6 for sometimes and had no problem.

anonymous Tue, 04/08/2014 - 10:08

Getting the drivers to integrate with your system is the priority. The very first thing you should do is visit the Focusrite website and make sure that the drivers for your device are current for the OS you are running.

If the drivers you have are current, then you need to make sure that you have no other audio devices active on your system. This includes things like built-in sound cards, hi definition audio drivers, all the audio stuff that came resident with your computer when you bought it. You don't need to uninstall them, but you should at least disable all of these devices and drivers. Make sure that the Focusrite is the only audio device that your system recognizes across the board.

Adding to what PC mentioned, you'll probably find that you will have to adjust these buffer settings from time to time, as a project goes through its various phases, and when the production gets to be more memory hungry as more processors/plugs and VSTi's are used.

The general rule of thumb - and there are exceptions, I'm talking "in general"- is that you should set your buffers for the most minimal setting you can get by with for recording, without having freeze-ups or stutters...and increase the buffer settings for mixing.

Decreasing the buffer settings will give you less latency while tracking; but if the amount is too small, you can run into glitches...stutters, hangups, freezes.
Because latency isn't as crucial when it comes time to mix, you should increase your buffer size. In fact, depending on your core processor speed and RAM amount, buffer settings as high as 2048 are not out of the question if you are mixing a dense production.

If you are unsure of your system's ability to handle audio production, you should visit this site: - and DL and run Latency Monitor. It scans your system and tells you where you might have issues.
You need to run this latency monitor while you have your recording software open and active. You don't have to play anything, just have it open while you run the scan.

Also....PC posted a link to a very well-written article a few days ago that explains how to maximize your system for audio production if you are using Windows 8: