Skip to main content

Hello friends,

I'm seeking help to determine the problem I'm having when recording a MIDI file from my electronic drum kit.

Alesis Crimson Mesh Head Electronic Drum Set
USB MIDI cable (direct from the ekit to my computer)
Samsung laptop
Sony Acid Pro 7
Line 6 POD Farm
Line 6 TonePort UX2

My audio engineer wants me to record both an audio and MIDI file of my drum tracks so he can more manipulate the MIDI file to make it sound more like an acoustic set when I record songs for my music project. The audio file is important because I need to listen to it when I record the guitars, bass, and vocals. Then when my engineer puts it all together, it sounds better because we're not using the audio file from the ekit.

Problem: When recording the MIDI file, I don't get a MIDI file that completely matches the audio file. For some reason, the MIDI file will not record certain parts of the song (it kind of "drops out") or it looks like it records a trigger that is being "held down." I've attached two pictures. You'll see in the "Midi Ish" file, my audio engineer reports that there are MIDI notes that are just "missing" in the middle of the song, but looking at the audio track, which is shown at the bottom of the same image, shows that there are plenty of drum beats in that same period. The second image (MIDI Problems) shows the other issue I mentioned: where the MIDI recording looks like it's continuously recording a trigger (as if I'm holding down a piano key), yet I'm not actually doing anything. In the beginning, you'll see that the MIDI file is picking up each trigger, but then about 25 seconds in, something happens and it shows a constant MIDI trigger, although nothing is happening.

Solution I'm Seeking:
I think it's clear that I'd like to be able to find out why the MIDI file is either a) dropping out, b) not recording correctly, or c) whatever else is going on, and how I can solve the issue to allow me to record a full MIDI recording of my drum ekit that my audio engineer can work with.

Thank you.


Attached files


DogsoverLava Sat, 07/29/2017 - 16:26

Are you sure you have not got a hidden take selected at the splits? In Reaper where you have Takes in lanes you can inadvertently select a portion of another take (or a blank portion of another take) and not see that that's actually what's playing... Make sure your actually midi track is not having this kind of thing happen.

bucki4lyfe Sat, 07/29/2017 - 17:06

Thanks for the response. Yeah, I don't think that's an issue I'm running into. I did happen to manage a small breakthrough today, and I think it comes down to my driver I'm using. I played with some different settings and found that when I use the UX2 driver, I get a really good MIDI file, but the track would get messed up when I used the ASIO4ALL driver. The problem with using the UX2 driver for audio recordings is that I actually get a double sound, so it's difficult to record the drums using that driver. So, my short-term solution is to record a drum track using audio cables and the ASIO4ALL driver (to get the best sound, lowest latency, and no double sound), then record a MIDI drum track on top of the original audio track using the UX2 driver.

Unless anyone has any other thoughts :)

DonnyThompson Sat, 07/29/2017 - 17:54

Have you tried bulking all control codes except for notes and velocities?
Do you have any other midi devices or interfaces connected to your system?
How long is your midi cable?
You're sure you have the right midi input selected on your DAW track?
Are you TXing on Omni or on one specific channel, and is your DAW (midi track) set up to RX on Omni as well?

bucki4lyfe Sun, 07/30/2017 - 06:36

DonnyThompson, post: 451589, member: 46114 wrote: Have you tried bulking all control codes except for notes and velocities?
Do you have any other midi devices or interfaces connected to your system?
How long is your midi cable?
You're sure you have the right midi input selected on your DAW track?
Are you TXing on Omni or on one specific channel, and is your DAW (midi track) set up to RX on Omni as well?

Donny, thanks for the response. I'll try to answer your questions one by one

1) I'm not sure what you mean by bulking all control codes, so I'll have to plead ignorance on that one.
2) The only actual MIDI device connected is the Alesis drum kit, but Acid Pro recognizes the UX2 as a MIDI controller as well (though I'm not sure how or why other than because it's connected via USB).
3) The MIDI cable is 15 feet
4) I think I have the right MIDI input selected because if you look at the "MIDI Problems" picture above you'll see that "USB2.0" is selected as the MIDI input (USB2.0 refers to the USB MIDI cable coming from the drum kit.
5) I'm not sure what TXing or Omni refers to, but I am pretty sure I am recording to one specific channel/track via Acid Pro.

I'm happy to give more information if you think it would be helpful, and sorry for not knowing some of the other phrases/references you used here.

DonnyThompson Sun, 07/30/2017 - 10:33

Sorry. Damn spell check. "Bulking" should have read "Nulling", which zeroes out and deselects certain midi control codes. In your midi preferences section of your DAW, you should be able to select which midi data you want to record... things like velocity, duration, aftertouch, sustain, etc. I was suggesting you may want to deselect (null) everything except the note on/off and velocity parameters. Things like sustain, expression and aftertouch shouldn't matter with drum triggering anyway.
You're concerned with actual note on-off and velocities (volume and power), which can change the way drums sound, so you want to keep that one.

TX and RX are midi speak for transmit and receive. You may want to try setting your drum module to transmit on all channels (Omni) and set your DAWs midi track to receive the same, as opposed to selecting one specific channel.

15' should give you no problems. I'm doing a project now where we are recording both the audio and the midi from a synth, and the midi cable is 50'. We've had no problems with that cable length.

Another thing to check... to make sure that all the kit pieces are set to transmit on Omni.
You'll want to try selecting different channels for the pieces at some point, but for now we are trying to diagnose your situation and be able to get a successful recording of the kit as a whole. We can talk about different channels and tracks for the kit pieces later.

Also... some DAWs allow you to set an input quantization, a feature which automatically quantizes the data to a specific resolution on the way in during the recording ( 1/4, 8ths, 16th's etc ) if your DAW does have this midi track feature, Disable it, set it for no input quantizing.

The thing with the midi in your scenario is that you have two devices to contend with - the actual midi tone module (your drum module) and your DAWs midi input configuration.
Try setting both devices to TX and RX in Omni, and see if the midi configuration menu on your DAW allows you to select which midi data you want it to receive. I have zero experience with Acid ( LOL... at least the DAW platform anyway) so I'm just throwing out possible things to check. Maybe one of our other members has more experience with that program and could chime in. Try the things I suggested and post back if it helped or not.


User login