Skip to main content

Phantom power lost Mackie onyx 4080

Mackie Onyx 4080 made a pop sound and all phantom power was lost. Includes the 12 v. to the console lights. Any thoughts on where to look? Is there a fuse for the DC? I am searching around and so far cannot find a clue to what happened. Maybe we lost a transformer? The mixer functions fine otherwise.

Comments

djmukilteo Sun, 04/13/2014 - 18:22

I doubt you'll find anything out there. You might contact Mackie and see if they will sell or send you the service manual & schematics.
If you're a good electronic service tech you should be able to open it up and find the power supply board. Then find the problem with a meter and scope. Then replace the blown parts...power supplies are pretty straightforward. No idea what you did to cause that power supply to fail, but you might get lucky and find some destroyed components when you look inside...
The other option is to find a local service shop.

Boswell Mon, 04/14/2014 - 05:17

I don't know the way the power supplies in those Mackie consoles are wired, but there is likely to be a 12V secondary winding on the main transformer to supply the console light (a.c.) and also the 48V PP via a voltage-quadroupler rectifier. They may have put a fuse in the 12V a.c. line from the transformer and that's what you heard blowing, but it's also possible that they didn't and the main transformer 12V secondary winding is burnt out. If the latter, it would mean either replacing the transformer or finding room for another 10W transformer inside the chassis.

Boswell Mon, 04/14/2014 - 05:42

I've just found some further information on the Mackie Onyx 80 series consoles, and this indicates that they have an option for an external redundant power supply. The internal unit is almost certainly a switch-mode supply, as there is no voltage selector switch. This means that the console does not have a line-frequency mains transformer.

Your best plan is to check inside the console for blown fuses. You could also consider using an external supply if you can find one at a reasonable price, but there's no guarantee that the problem is not after the power generation and that using an external power supply would make any difference.

RemyRAD Mon, 04/14/2014 - 13:29

UM... it might just be easier to build up a small +48 V power supply? It's cheap. Everything ya need at Radio Shaft. The 3.6 K Phantom distribution resisters are already connected to each and every XLR microphone input. So even only need to find that one supply line. Drill a hole on the back of your Mackie, and stick a connector on. Cheap, fast, dirty. It works.

Mackie shouldn't have any problems supplying you with an actual schematic? They don't have " Proprietary " blah blah, underwhelming microphone preamp's like Avid's/Digi, M-Box's. Or should that be " Box' "?

I don't know none engineers that can write English good?
Mx. Remy Ann David

cjwieboldt Tue, 04/15/2014 - 19:04

I pulled the power supply. Found a spot where maybe a resistor blew out. Scorched spot on the pcb and soot on nearby components. I found a used external power supply and the fellow overnighted it to me. Plugged it in and the 48v seems to work fine. The 48v indicator light on top of the console came on but the 12v indicator did not. All indicators light up on the ps. We ran through all our condensers and they all seem to work fine. I had pulled the lights off the board when the ps went out and I am nervous putting them back on. Not sure what caused this.

x

Register

Your recently read content