Skip to main content

EMU 1820m problems...please help

Ok, Im in a jam and need some assistance. I run a 3.2ghz pentium 4 with 1gb ram and a emu 1820m card and audio dock. I have had this installed with no problems since this card has come out, routinely updating the software when it is available. So heres the problem, I left my computer on overnight( not uncommon) and when I arrived in the morning, the audiodock was lit up like the 4th of july, and it wasnt being recognised by my computer, or even accessable to reinstall drivers. I have removed the audio dock, cards, drivers and program. Reinstalled everything with the new version 1.82 of the patchmix software and still I cannot even get my audiodock to light up, be recognised, play audio or anything. I downloaded and uninstalled and reinstaled all drivers according to the New available driver patch. But still no luck. unfortunatly my original instalation CD is in another state 2000 miles away and I have a session in 2 days. .Now my question is. does anyone in the Orange County California area have a 1820M that maybe I can meet up with and test my audiodock or borrow there software instalation CD. The reason I need the original CD is I think the downloadable Patchmix program is just an update, even though the creative rep insisted it was a full install program, for some reason I dont believe him. so I would like to see if I can load an older version of patch mix and see if I can bring my audiodock back to life. .

Has anyone had any similar problems with this unit?

Does anyone have any suggestions in how to fix my problem?

Does anyone have an original install CD that came with the 1820m that they could copy and zip the files for me and email them to me. I would love you forever...?...

Thank you and I hope someone can help me.

Pistol Pete Heinz


AudioGaff Thu, 01/04/2007 - 08:42
The AudioDock does the Christmas tree thing most often when it loses communication or power with the PCI card that can be caused by many different reasons.

Search the E-MU FAQ and try the E-MU Bruce Virgin Reinstall routine. Assuming that there is no problem with your computer, check the EDI cable is fully connected to the connectors on both ends. Bad connection, connectors or EDI (CAT5) cable are also related to X-mas tree condition.

Since this is more a DAW topic, it will moved to that forum.